Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78879

Summary: DataManager crashed when browse the database talbes.
Product: [Retired] Red Hat Linux Reporter: Need Real Name <yonghuazh>
Component: mysqlAssignee: Patrick Macdonald <patrickm>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?archive=no&bug=149952
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-12-02 18:06:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Error Messages gived by DataManager:

DataManager: relocation error: /usr/lib/libmyodbc.so: undefined symbol:
_init_dynamic_array

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start mysql
2.setup myodbc driver and system DNS source in ODBCConfig
3.test ODBC with DataManager
    1). Expand ODBC
    2). Expand System Data Sources
    3). Expand mysql(for mysql database), input the account and passwd
    4). Expand Tables --- crashed.

Actual Results:  DataManager: relocation error: /usr/lib/libmyodbc.so: undefined
symbol: _init_dynamic_array

Expected Results:  Browse Tables, and then, browse my table ...

Additional info:

Debian fixed it already.
http://bugs.debian.org/cgi-bin/bugreport.cgi?archive=no&bug=149952

Comment 1 Fernando Nasser 2003-02-13 14:58:47 UTC
This is a binary incompatibility problem between the libmysqlclient10 and
libmysqlclient9 (as the referenced Debian bug shows).

Changing component to mysql. We have a mysqlclient9 component -- was that just
mysqlclient (without the version qualification) I would have sent it there.

Comment 2 Patrick Macdonald 2003-02-13 17:14:16 UTC
This is a duplicate of 77635

*** This bug has been marked as a duplicate of 77635 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.