Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78810

Summary: /usr/lib/sendmail symlink missing
Product: [Fedora] Fedora Reporter: Nathan G. Grennan <redhat-bugzilla>
Component: postfixAssignee: John Dennis <jdennis>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: chris.ricker, mitr, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-02-25 00:49:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nathan G. Grennan 2002-12-01 03:43:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021127

Description of problem:
The sendmail package for RedHat 7.3 has a symlink in /usr/lib called sendmail
that links to ../sbin/sendmail aka /usr/sbin/sendmail. Usermin, a cousin of
Webmin, seems to expect /usr/lib/sendmail. Since postfix is supposed to be a
drop in replacement for sendmail, and it is just a symlink to the binary already
included it seems perfectly reasonable to add it and make the postfix package a
better drop in replacement for sendmail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -i postfix-*.rpm
2. ls /usr/lib/sendmail
3. rpm -qf /usr/lib/sendmail
4. rpm -ql postfix | grep '\/usr\/lib\/sendmail'
	

Actual Results:  No such file or directory
No package owns /usr/lib/sendmail
<Nothing>


Expected Results:  /usr/lib/sendmail
postfix
/usr/lib/sendmail


Additional info:

I understand this may require some alternative package management since the
sendmail package already owns /usr/lib/sendmail.

Comment 1 Nathan G. Grennan 2003-01-15 12:14:40 UTC
Still no /usr/lib/sendmail symlink in the latest rawhide, postfix-1.1.11-8.

Comment 2 John Dennis 2003-06-12 19:43:21 UTC
This should work if you use alternatives. Postfix and Sendmail are managed by
"alterantives" under the name "mta". 

[root@athlon root]# ls -l /usr/lib/sendmail
lrwxrwxrwx    1 root     root           16 May 19 16:00 /usr/lib/sendmail ->
../sbin/sendmail
[root@athlon root]# ls -l /usr/sbin/sendmail
lrwxrwxrwx    1 root     root           21 Dec 10  2002 /usr/sbin/sendmail ->
/etc/alternatives/mta
[root@athlon root]# ls -l /etc/alternatives/mta
lrwxrwxrwx    1 root     root           26 Mar 26 12:41 /etc/alternatives/mta ->
/usr/sbin/sendmail.postfix

Is this what you are seeing? It should be.


Comment 3 Chris Ricker 2003-12-11 23:46:40 UTC
This is actually still broken with 2.0.16-1 on fedora

The problem is that

/usr/lib/sendmail -> /usr/sbin/sendmail

is a symlink provided by the sendmail rpm. If you don't have sendmail
installed, postfix doesn't supply it like it should.

The probable correct fix is for that symlink to be added to the
postfix rpm (it shouldn't conflict with sendmail to do so)

Comment 4 John Dennis 2004-02-25 00:49:37 UTC
Actually I think this has to be managed with alternatives and that
file ownership would conflict otherwise. Sendmail currently has this:

--slave /usr/lib/sendmail mta-sendmail /usr/lib/sendmail.sendmail \

I've added this to postfix:

--slave /usr/lib/sendmail mta-sendmail
%{postfix_command_dir}/sendmail.postfix

I think that should take care of things, both links will be managed by
alternatives.