Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78807

Summary: fonts rendered at wrong size (smaller) in gnome-terminal in vnc
Product: [Retired] Red Hat Linux Reporter: Kevin Street <street>
Component: vteAssignee: Warren Togami <wtogami>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr, nalin, otaylor
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-22 23:26:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kevin Street 2002-12-01 00:30:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When viewed in vnc, gnome-terminal's fonts are rendered at a much smaller  size
than when viewed in X.  All other application's fonts appear the same in X and
vnc.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start vncserver
2.connect to it with vncviewer
3.open a gnome-terminal
4.see the teeny-tiny fonts	


Actual Results:  font rendering in gnome-terminal is much smaller in vnc than in X

Expected Results:  fonts should look the same in vnc

Additional info:

- display size 1280x1024 in both X and vncviewer
- dpi set to 75 in both
- tried from windows and linux vncviewers
- tried "use same font as other apps" in gnome-terminal
- tried specifying font and size (eg monospace 10) in g-t profile
- tried other font names, they all do the same thing

I can get the gnome-terminal fonts to look similar in vnc by changing to eg.
monospace 14, but then they're HUGE when I go back to X.  I need to keep
switching the font size back and forth but at least that gives a workaround.

Comment 1 Havoc Pennington 2002-12-01 01:01:01 UTC
I can't reproduce; if I start gnome-terminal in vncviewer then it has 
the same fonts as my regular gnome-terminal.

What is the output of "xrdb -query" on regular X and on your VNC X?
Specifically the Xft.dpi value.

Comment 2 Kevin Street 2002-12-01 01:54:47 UTC
xrdb -query on vnc

Xft.dpi:        96
Xft.hinting:    true
Xft.hintstyle:  hintmedium

xrdb -query on X
Xft.antialias:  1
Xft.dpi:        96.000000
Xft.hinting:    1
Xft.hintstyle:  hintmedium
Xft.rgba:       none

I now see that I'm also getting this message in the vnc log:

Xlib:  extension "RENDER" missing on display ":1.0".

for some applications, but not for gnome-terminal.  For example I get this
when I start the system monitor which displays correctly. 


Comment 3 Havoc Pennington 2002-12-01 02:19:59 UTC
That's strange. Also, 8.0 shipped with an Xft bug causing huge memory leaks in 
all Xft apps when using a non-RENDER server - I wonder why you aren't seeing
that?

Does the gnome-terminal menubar also have smaller text than say the 
gnome-system-monitor menubar, or is it only the terminal area itself?

What is the output of "rpm -q vte gnome-terminal Xft fontconfig freetype pango
gtk2"?


Comment 4 Kevin Street 2002-12-01 02:56:37 UTC
I'm just setting up vnc, so I probably just haven't noticed the memory leaks
yet.  (yikes! just watched system monitor in vnc ... leaks about 0.1 MB / sec)
Is there a patch?

Only the terminal area has a small font.  The title, menu bars, menus and pop up
dialogs look normal.

vte-0.8.19-1
gnome-terminal-2.0.1-5
Xft-2.0-1
fontconfig-2.0-3
freetype-2.1.2-7
pango-1.1.1-1
gtk2-2.0.6-8
vnc-3.3.3r2-39


Comment 5 Havoc Pennington 2002-12-01 03:35:04 UTC
There is a patch for the Xft memory leak, but hasn't made it through 
the errata pipeline yet. It's just adding a couple of XDestroyImage()
calls.

I'm not sure what else to guess at here, adding some cc.

Comment 6 Ray Strode [halfline] 2004-11-09 18:41:08 UTC
Hi Kevin,
Are you still seeing this?

Comment 7 Kevin Street 2004-11-09 20:19:21 UTC
I don't know.  This was submitted on RH8.  I'm now on FC2 and don't
have   vnc set up at the moment.  I'm going to install FC3 in the next
few days and can play with vnc there.

If it hasn't appeared to anyone else you can close this and I'll
reopen    it if I see it on a current system.