Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78789

Summary: CID-keyed fonts available free at ORA ftp archive not included in ghostscript(-font)
Product: [Retired] Red Hat Linux Reporter: Jungshik Shin <jshin>
Component: ghostscriptAssignee: Tim Waugh <twaugh>
Status: CLOSED WONTFIX QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: alexcher
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-07 14:50:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jungshik Shin 2002-11-30 00:25:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021008

Description of problem:
Ken Lunde (the author of CJKV information processing and
the man behind CJKV fonts at Adobe) put up a set of 
sample CID-keyed fonts at
ftp://ftp.oreilly.com/pub/examples/nutshell/cjkv/adobe/samples/
They're refered to in /usr/share/ghostscript/7.05/lib/CIDFnmap.*,
but they're not installed in /usr/share/ghostscrpt/Resources/CIDFont.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	Make a simple postscript file  that refers to a truetype font 
   as a CID-keyed font. For instance, the following PS file will do it.
-------Cut----Here----------
%!PS-Adobe-3.0
/Munhwa-Regular-UniKS-UTF8-H findfont 50 scalefont setfont
10 100 moveto
<ED959CEAB880> show
showpage
%%EOF
-----------Cut----------Here
2. Try to view it with 'gs' or 'gv' 
 



Actual Results:   Instead of Korean characters, Latin alphabets show up
with the error message that gs can't find font  
'Munhwa-Regular-UniKS-UTF8-H' so that it's
replaced by 'Courier'.  Or, gs doesn't show 
anything with the error message 
'/undefinedresource in --findresource--'

Expected Results:  Two Korean characters should be printed with Munhwa-Regular 
font. 

Additional info:


Barring any potential license issue (there is none afaik.), 
it'd be nice to put them in either /usr/share/ghostscript/Resource/CIDFont
or in /usr/share/fonts/<lang>/CIDFont (where <lang> is ja, zh-TW, zh-CN and
ko.  Note that /usr/share/fonts/<lang>/CIDFont don't yet exist
on RedHat 8.0) along with the corresponding afm files in appropriate place (e.g.
/usr/share/fonts/afms). If the latter is chosen (which is better
because that way, CID-keyed fonts can be visible to 
xfs and possibly Xft/fontconfig),  symbolic links to them have to be
made in /usr/share/ghostscript/Resource/CIDFont so that ghostscript
can access them. fonts.scale files have to be made in
/usr/share/fonts/<lang>/CIDFont directories as well as fonts.dir. 

In addition, the following line (currently commented out)
in /usr/share/ghostscript/7.05/lib/CIDFnmap has to be
'activated'.

%(CIDFnmap.Ore) .runlibfile


Related to this bug is bug 78788.
I filed this for ghostscript because '/usr/share/ghostscript/Resource/CIDFont'
directory belongs to 'ghostscript' component, but I guess it's
better to be put in 'ghostscript-fonts' component.

Comment 1 Jungshik Shin 2002-11-30 00:28:10 UTC
Changing serverity to 'enh'. Sorry for spamming.
BTW, as for the license of CID-keyed fonts at ORA ftp site,
at least Korean Munhwa fonts have X11-like license (they're
released by South Korean Ministry of Culture as free fonts
and Ken Lunde wrapped them as CID-keyed fonts). 
I guess other fonts (Japanese and Chinese) were also released under 
pretty liberal license terms.

Comment 2 Tim Waugh 2002-12-23 12:19:37 UTC
Need to check the license pretty carefully first.

Comment 3 Alex Cherepanov 2005-03-07 12:12:56 UTC
Non-copyleft license of the original work doesn't protect the
derived work from being distributed under non-free license.

I tried to check the license some time ago. There's none on the site.
They don't respond to email either.



Comment 4 Tim Waugh 2005-04-07 14:50:59 UTC
Think we'll have to close this.