Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78453

Summary: basic /sbin/* files need libraries outside of the root-partition
Product: [Retired] Red Hat Raw Hide Reporter: Enrico Scholz <rh-bugzilla>
Component: modutilsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 1.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-23 01:37:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Enrico Scholz 2002-11-23 01:37:31 UTC
Description of Problem:

| $ ldd /sbin/modprobe
|           libz.so.1 => /usr/lib/libz.so.1 (0x4002a000)
                         ~~~~~~~~~

(same holds for depmod)

This causes problems on startup when having a seperate /usr-partition, because
certain operations in /etc/rc.sysinit can not be executed.

Perhaps libz.so.1 should be placed inside /lib, so reassign if needed.



Version-Release number of selected component (if applicable):

modutils-2.4.21-1
zlib-1.1.4-5



How Reproducible:


Steps to Reproduce:
1. configure system to have a seperate /usr partion
2. reboot


Actual Results:

Errormessages because libz.so.1 can not be found.

Comment 1 Bill Nottingham 2002-11-25 21:53:05 UTC
Fixed in 2.4.22-1.