Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78443

Summary: Application quits when loading
Product: [Retired] Red Hat Linux Reporter: Need Real Name <eric.drommer>
Component: redhat-logviewerAssignee: Tammy Fox <tammy.c.fox>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-26 22:38:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-22 22:27:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run redhat-logviewer

Actual Results:  applocation quits

Additional info:

(redhat-logviewer.py:1488): Gdk-WARNING **: locale not supported by Xlib

(redhat-logviewer.py:1488): Gdk-WARNING **: can not set locale modifiers
unable to translate from iso-8859-1 utf-8
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 123, in ?
    sysClass = LogFileClass.LogFileClass("SYSLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 117, in
insert_into_buffer_at_offset
    self.insert(iter, line, -1)
TypeError: GtkTextBuffer.insert() argument 2 must be string without null bytes,
not str

Comment 1 Tammy Fox 2002-11-26 16:33:48 UTC
It looks like you might have a locale problem that prevents the application
from reading your log files. Please provide the output of the command 'echo
$LANG' and your /etc/sysconfig/i18n file.

Comment 2 Need Real Name 2002-11-26 22:38:45 UTC
It's loading now, don't know why. But it prompts still warnings:

(redhat-logviewer.py:996): Gdk-WARNING **: locale not supported by Xlib

(redhat-logviewer.py:996): Gdk-WARNING **: can not set locale modifiers
sh: line 1: /usr/sbin/tux2w3c: Datei oder Verzeichnis nicht gefunden


echo $LANG :

de_DE.utf8


/etc/sysconfig/i18n :

LANG="de_DE.utf8"
SUPPORTED="de_DE.UTF-8:de_DE:de"
SYSFONT="latarcyrheb-sun16"

Comment 3 Tammy Fox 2002-12-12 19:27:55 UTC
I don't get that message when I set LANG to de_DE.utf8. You might have
an older version of Xlib that doesn't support UTF-8 locales.

I'm closing this bug since it starts for you and I can't reproduce it.