Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78427

Summary: Lockup on Dell 2650 with kernel-2.4.18-18.8.0smp
Product: [Retired] Red Hat Linux Reporter: Need Real Name <bmilner>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: peterm
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-11 20:30:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
lspci -v output
none
cat /proc/modules none

Description Need Real Name 2002-11-22 18:48:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
Machine hard locks up with an oops. The oops does not get written to
disk.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
Can't reliably reproduce. It seems to be random.


Additional info:

Sorry about the incomplete oops, these were copied by hand
by hand from the console in a hurry. The machine locked up
twice. The mouse seemed to still work on the first lockup,
but I couldn't change consoles to see the oops. The second
time a few minutes later this appeared on the console and the
machine was locked up. I have since backed down to 2.4.18-14smp
to see if this will work. I'll try to get a complete one if it
happens with the slightly older kernel. 

EFLAGS: 00010046

EIP is at show_stack [kernel] 0x4b (2.4.18-18.8.0smp)

... missed a few lines - in a hurry ...
Process keventd (pid: 6, stackpage = f7fb3000)
Stack: c0273404 00000001 00000001 00000003 c010ac19
f8000660 00000001 00000003
ffffffff 00000003 c0f0bb88 c0273633 00000003 f4df1000 
c010ad32 00000003 00000001 c018d257 f657fea0 c46ce000
c46dfb4 c011d104 f4df1168 c0338364


c010ac19 show kernel 0x139 (0xf7fb3f24))
[<c010bb88>] wait_on_irq [kernel] 0xf8 0xf7fb3f24
[<c010ad32>] __global_cli [kernel] 0x62 0xf7fb3f4c
[<c018d257>] flush_to_ldisc [] 0x127 0xf7fb3f58
[<c011d104>] schedule [] 0x184 0xf7fb3f68
[<c0126c6a>] __run_task_queue [] 0x6a 0xf7fb3f80
             context_thread
             context_thread
             stext 0x0 0xf7fb3fe8
             kernel_thread
             context_thread


The system is a Dell 2650, with 2G of ram and a perc raid controller.

Comment 1 Need Real Name 2002-11-22 18:49:16 UTC
Created attachment 86084 [details]
lspci -v output

Comment 2 Need Real Name 2002-11-22 18:50:17 UTC
Created attachment 86085 [details]
cat /proc/modules

Comment 3 Need Real Name 2002-12-11 20:27:20 UTC
The same machine has now been running 19 days without a problem
using a previous 2.4.18-14smp kernel. It appears that the
newer errata kernel is unstable. BTW, the errata kernel has a
newer version of the aacraid driver (may or may not be related).

Nov 22 09:33:10 fido kernel: Red Hat/Adaptec aacraid driver, Sep  4 2002
Nov 22 09:13:23 fido kernel: Red Hat/Adaptec aacraid driver, Nov 13 2002


Comment 4 Jeff Garzik 2002-12-11 20:32:57 UTC

*** This bug has been marked as a duplicate of 69920 ***