Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78379

Summary: man displays garbled characters in xterm
Product: [Retired] Red Hat Linux Reporter: Dan Kegel <dank>
Component: xterm-colorAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: brent_thompson, dickey, dorn, kurquhart, michal, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-13 01:10:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dan Kegel 2002-11-21 22:47:41 UTC
Description of problem:
man displays garbled characters in xterm when man is outputting
UTF-8, even if xterm's utf-8 support is enabled

Version-Release number of selected component (if applicable):
rpm -q -f `which xterm` reports XFree86-4.2.0-72
xterm -version reports XFree86 4.2.0(165)
rpm -q -f `which konsole` kdebase-3.0.3-13

How reproducible:
Always

Steps to Reproduce:
1. run xterm or konsole
2. type 'man man'
3. note that all hyhpens in output are garbled
4. run xterm -u8
5. type 'man man'
6. note that all hyphens in output are invisible
	

Additional info:

This is not a bug in man; it's a bug in xterm.
A similar bug exists in konsole; see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=73810
(and http://bugs.kde.org/show_bug.cgi?id=38347
which snidely says RTFM despite the fact that
the doc for konsole says absolutely nothing about utf-8)

One workaround is to give the command
  export LANG=c
Another is to run gnome-terminal, which handles
utf-8 properly.

This problem is related to the following other bugzilla entries:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=70381 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=70733 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=72592 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75702
which mistakenly blame the problem on man.

Comment 1 Michael Lee Yohe 2002-11-22 18:41:21 UTC
Refer to Bug 78392 for a workaround.

Comment 2 Thomas E. Dickey 2003-01-27 01:22:06 UTC
I thought this was obvious - but for the record, Redhat should have rolled
the uxterm script's resources into xterm if they chose to set a UTF-8 locale
system-wide. See

http://invisible-island.net/xterm/xterm.log.html#xterm_160

(anyone can run uxterm, but some people insist on it being called "xterm")


Comment 3 Ben LaHaise 2003-02-19 16:31:37 UTC
Additionally, running xterm with -u8 still results in some characters not being
displayed correctly: for example, the AUTHORS section of man xterm appears
different on xterm -u8 as compared with gnome-terminal.

Comment 4 Thomas E. Dickey 2003-02-20 00:11:12 UTC
apparently no one read (or understood) my comment.

Comment 5 Jason Vas Dias 2005-10-13 01:10:10 UTC
I cannot reproduce this problem with the latest rawhide version xterm-205-1 , 
using uxterm or the LC_ALL=en_US.UTF-8 locale and xterm -u8 . Hence, this 
bug is being closed . If it is still a problem for you, please re-open.