Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7828

Summary: sort is broken
Product: [Retired] Red Hat Linux Reporter: Doug Ledford <dledford>
Component: textutilsAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-17 14:33:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Doug Ledford 1999-12-16 01:43:15 UTC
The sort utility defaults to folding lower case to upper case.  This is
only supposed to be enabled when the -f flag is given, and there is no
means to turn it off.  This in turn breaks the use of ctags to make tags
files for vim to use since vim requires sorted tag files that don't fold
lower and upper case letters when sorting.

Comment 1 Bernhard Rosenkraenzer 1999-12-17 14:33:59 UTC
It's not a bug, it's a feature.
sort now respects locales.
What you want to do is setting LC_ALL=C before using sort.