Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78252

Summary: IMAP folder namespace is ignored
Product: [Retired] Red Hat Raw Hide Reporter: Michael Lee Yohe <michael>
Component: evolutionAssignee: Jeremy Katz <katzj>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-20 17:21:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Lee Yohe 2002-11-20 17:21:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Most email clients under Linux tend to store email in directories underneath
~/.mail - prior to Evolution 1.2, you could specify to override the server
provided folder namespace so that all saved folders are located underneath
~/.mail (you can do this by configuring the options under Mail Account settings).

When you subscribe to a "mail folder" underneath ~/mail - the folder list in the
left pane of Evolution would show something like the following:

INBOX
|
- Miscellaneous Mail
  |
  - Jokes
  - Information

With Evolution 1.2, ~/.mail shows up as a subfolder (even if you attempt to
override the namespace):

INBOX
|
- ~/mail
  |
  - Miscellaneous Mail
    |
    - Jokes
    - Information

This is not normal behavior in most working IMAP client email applications.  The
old trick was to delete all configured email servers, remove the ~/.mailboxlist
file, add the servers back (and properly configure them), and then re-subscribe
to the folders.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description.	

Actual Results:  ~/.mail appears as a subfolder.

Expected Results:  ~/.mail should be handled transparently by Evolution and
should not appear in the folder list.

Additional info:

$ rpm -q evolution
evolution-1.2.0-2

$ rpm -q imap
imap-2001a-15

Comment 1 Jeremy Katz 2002-11-22 17:23:58 UTC
This is an intentional change in behavior of the new version.

Comment 2 Francesco Gorini 2004-12-28 19:49:29 UTC
Many IMAP clients have this option, then why disable it ?!?
Think about how many users won't choose Evolution for this behaviour !

I think this option should be left working.

My users already told that won't use Evolution for this ! (they are
working with Mozilla, but I'm trying to switch to Evolution because
it's more featured with calendars, etc...)