Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78120

Summary: Network Config Util Crash
Product: [Retired] Red Hat Linux Reporter: Need Real Name <gte984s>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-19 09:16:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-19 07:42:02 UTC
Traceback (innermost last): 
  File "/usr/sbin/neat", line 1402, in ? 
    gtk.mainloop() 
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop 
    _gtk.gtk_main() 
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__ 
    ret = apply(self.func, a) 
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked 
    interface = NewInterfaceDialog() 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py", 
line 82, in __init__ 
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid) 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py", 
line 101, in __init__ 
    self.hwDruid = ethernetHardware(self.toplevel) 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", 
line 64, in __init__ 
    self.setup() 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", 
line 118, in setup 
    list.append(modInfo[i]['description']) 
KeyError: description 
 
Local variables in innermost frame: 
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84db238> 
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 
'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA 
wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 
wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan 
NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 
'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com 
EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron 
E2100', 'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 
'Allied Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 
21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 EISA', '3Com 
3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 
'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 3200', 
'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments 
SB1000'] 
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 
8548e60> 
i: defxx

Comment 1 Harald Hoyer 2002-11-19 11:33:42 UTC
third beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.3 version... Thx
and please test.

*** This bug has been marked as a duplicate of 76446 ***