Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7805

Summary: Ascii print filter failing.
Product: [Retired] Red Hat Linux Reporter: Richard Schaal <rschaal>
Component: lprAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: rhw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-14 18:31:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Richard Schaal 1999-12-14 18:15:23 UTC
After configuring a HP LaserJet 6P, I find that I can print postscript test
page with printtool, but the ascii test page fails.

This is after doing the quickie work-around for the failure to find the
parallel port at all.

This failure is not limited to the test page, but is a simple example.  -
all postscript prints that I've tried work, and all ascii text prints
fail.

I did not have this problem on another Linux box I have running 5.2 where
printer filter can handle a mix of text and postscript without problem.
There I had an epson ST800C printer.

Comment 1 Bernhard Rosenkraenzer 1999-12-14 18:31:59 UTC
That is perfectly normal. The HP LaserJet 6P can't print ASCII. It's a
PostScript only printer.
Printing ASCII in Linux just sends raw text to the printer, which the HP LJ 6P
doesn't handle.

You can use an ASCII to PostScript converter, such as mpage or a2ps, to print
plain text.

Comment 2 Richard Schaal 1999-12-14 19:19:59 UTC
Can you give a pointer to how to install a smart print filter that can do the
right thing?  I have such a filter, but need a little guidance on putting it
inline.
	Thanks!

Comment 3 Riley H Williams 1999-12-14 22:40:59 UTC
Related to this, although not part of the same problem, is it possible to
configure the Linux print server to have a "printer" that forwards the print
request to a remote printer on the system the user is telnet'd in from?

Comment 4 Richard Schaal 1999-12-15 02:59:59 UTC
The initial response was BOGUS.  The capability to print a mix of input types is
already in the print system.  The answer to the question is to deselect the
"Fast text printing (non-PS printers only)" - this causes the input to be
converted to postscript | ghostscript filter.

Comment 5 Richard Schaal 1999-12-15 07:22:59 UTC
As far as controlling which printer is used based upon user login - if you can
control the "PRINTER" environment variable you have it made.  Good Luck.!

Comment 6 uart 2000-01-10 02:54:59 UTC
Having similar problems with my HP-DJ 540 Text worked under RH5.2, but now only
postscript test will print. Not a mission critical prob, as i usually only need
to print from WordPerfect or Netscape, but it still kinda irks me.