Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 78045

Summary: libgnomecanvas binary rpm doesn't build
Product: [Retired] Red Hat Linux Reporter: Bernd Kischnick <kisch>
Component: libgnomecanvasAssignee: Alexander Larsson <alexl>
Status: CLOSED RAWHIDE QA Contact: Jay Turner <jturner>
Severity: low Docs Contact:
Priority: medium    
Version: 8.0CC: hp, srevivo
Target Milestone: ---Keywords: EasyFix, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-16 13:59:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579    
Attachments:
Description Flags
patch to the spec file none

Description Bernd Kischnick 2002-11-18 12:35:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8) Gecko/20020310

Description of problem:
Building a binary RPM from the source RPM fails, unless an old version of the
binary RPM is already installed on the build host.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm -e libgnomecanvas libgnomecanvas-devel
rpm -ivh libgnomecanvas-2.0.2-1.src.rpm
rpmbuild -bb SPECS/libgnomecanvas.spec
	

Actual Results:  rpmbuild fails in %install:
libtool doesn't find libcanvas-2.so to re-link libglade/2.0/libcanvas.so

Expected Results:  binary RPM should be built.

Additional info:

libtool wants to perform a re-link step to install libglade/2.0/libcanvas.so to
the build root. libtool assumes that libcanvas-2.so has already been installed
to its final destination, /usr/lib, but it's in the build root instead.

This can be fixed by pointing the environment var LIBRARY_PATH into the build
root while %installing.

Comment 1 Bernd Kischnick 2002-11-18 12:36:42 UTC
Created attachment 85404 [details]
patch to the spec file

Comment 2 Havoc Pennington 2002-12-14 02:19:17 UTC
Hmm, I thought we'd fixed libtool not to do this.

Comment 3 Jens Petersen 2002-12-16 07:46:41 UTC
We have, but it looks like the "ltmain.sh" in libgnomecanvas
wasn't generated with it...

(The relink patch is not upstream yet.)

Comment 4 Havoc Pennington 2003-01-02 23:19:45 UTC
Just need to run libtoolize in libgnomecanvas spec file I guess.

Comment 5 Alexander Larsson 2003-01-16 13:59:32 UTC
Fixed in libgnomecanvas-2.1.90-2. (I just added libtoolize -f to %build)