Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7803

Summary: file manager problems
Product: [Retired] Red Hat Linux Reporter: lmarx
Component: gnome-utilsAssignee: Jonathan Blandford <jrb>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: ddumas
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 23:09:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description lmarx 1999-12-14 15:45:52 UTC
1)at gnome login, after entering password, the error message:
                 you are running the GNOME file manager as root.
                 As root you can damage your system....

(and so on)
even though file manager does not launch at login
(it used to but was disabled with 'save settings' at shutdown)

also there is a pretty long delay in launching file manager..
about 20 seconds to get the error message, then file manager launches
normally.

history:
file manager launched at boot each time, until disbled using
'save settings' at shutdown.

the long delay began, i think,  after config of squid-2.2STABLE5 proxy
server.

Comment 1 Thomas D. Shepard 1999-12-20 00:07:59 UTC
I think I know the answer to this one, so I will comment in hopes of getting
you an answer before the RedHat staff returns from the weekend:

In section 13.1 of the RH Linux 6.1 getting started guide, we are told that
the gnome file manager is the entity that provides the gnome desktop
functionality. The file manager window is just a subsystem of it. Even if
you set your desktop settings to not display the file manager window when
you log in (as I also have done, I use dired under emacs for most of my
file management) the file manger is still running to manage your desktop.
And, you can still make mistakes that can clobber your system, since you
can have links to anything on your desktop. So you still get the warning
message.

Comment 2 Jonathan Blandford 2000-02-03 23:09:59 UTC
Indeed, that is correct.  the file manager controls the desktop, as well as the
windows.  If you want to disable it, you need to go to Startup Programs in the
control-center, find gmc, and remove it.  However, you should heed the warning
given by the message.  You really shouldn't be logging into X as root.  Log in
as a user and 'su' to root if you need to do something.