Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77986

Summary: Installing RH Linux 8.0 failed
Product: [Retired] Red Hat Linux Reporter: Need Real Name <jpawlyn>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: katzj, mharris, msf
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-19 10:16:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
Error dump
Output from "lspci -vvn" command none

Description Need Real Name 2002-11-16 18:37:30 UTC
Description of Problem:
The installation failed half way through and asked to save a log file to floppy 
which I did. On reboot, and trying the installation again, I get a 'reading 
header - cpio failed' message and am unable to proceed with the installation.

How Reproducible:
On every reboot.

Steps to Reproduce:
1. Disk 1 of 3 in CD-ROM.
2. Press enter when initial installation screen appears.
3. Installation bombs out and last message is 'You can safely reboot your 

Actual Results:

Expected Results:

Additional Information:

Comment 1 Need Real Name 2002-11-16 18:39:14 UTC
Created attachment 85325 [details]
Error dump

Comment 2 Charmaine Tan 2002-11-17 20:04:38 UTC
i'd also like to know how 2 solve this problem...?

Comment 3 Need Real Name 2002-11-19 09:13:21 UTC
The problem resolved itself when I appended MEM=32M to the boot option. 
However, after finishing the installation there was a CRC error on booting 
using GRUB. I appended mem=64m to the kernel option and Linux came up without a 
hitch.  I assume that Linux will only be accessing 64MB of RAM. Any ideas how I 
can use the whole 128MB on my machine?  I've tried booting with the command 
mem=96m but the CRC error reoccurs.

Comment 4 Michael Fulbright 2002-11-19 18:48:55 UTC
What chipset is your motherboard basde on?

Comment 5 Need Real Name 2002-11-21 01:35:30 UTC
The machine is a HP Vectra VL with a Pentium II processor.

Comment 6 Arjan van de Ven 2002-11-22 15:32:35 UTC
what video card is that ?
(it can be that you have a video card that "shares" (eg steals) ram and that
seems to get misdetected)

Comment 7 Need Real Name 2002-11-23 12:31:12 UTC
The video card is a Cirrus Logic GDS 465

Comment 8 Need Real Name 2002-11-23 12:53:38 UTC
Sorry misread it. It actually is a Cirrus Logic GD5465

Comment 9 Mike A. Harris 2002-11-25 12:41:10 UTC
This seems much more like bad media to me.  Is this an official boxed set
installation of Red Hat Linux, or is it a downloaded copy?  Either way,
try booting the install CD, with "linux mediacheck" to test your CDR
media prior to installation.  In particular the "cpio read failed" error
seems very indicative to me of bad media.

Comment 10 Need Real Name 2002-11-25 12:55:25 UTC
It is an official boxed set. No need to worry about the install since 
installation worked fine once I had appended mem=32M to the boot option. 
However, in order for GRUB to load the kernel, I need to append mem=64M as an 
option. This is inconvenient since the machine has 128M of RAM and is running 
painfully slowly, presumably because it is only accessing 64M of RAM.

Comment 11 Mike A. Harris 2002-11-25 13:00:04 UTC
Ok, even though this is a boxed set, booting with the mediacheck is
recommended.  Although very unlikely, it is possible that your media
is defective.  Testing it is the best recourse.

If the testing succeeds:

Does a text mode installation work?  Boot with "linux text" to try a
text mode install.

Comment 12 Need Real Name 2002-11-25 13:17:08 UTC
Text mode installation HAS worked. RedHat Linux using GNOME or KDE is working 
fine. What is not working is using Linux without restricting the memory to 
64MB. Surely if the install has worked fine, the subsequent memory problem is 
not going to be due to corrupted media?

Comment 13 Mike A. Harris 2002-11-25 14:04:48 UTC
That sounds correct.  Sounds to me like a kernel issue of some kind,
or a hardware issue.

Can you provide the complete output of "lspci -vvn" also?

Comment 14 Need Real Name 2002-11-25 22:50:12 UTC
Created attachment 86410 [details]
Output from "lspci -vvn" command

Comment 15 Need Real Name 2002-12-19 10:16:25 UTC
I replaced the 128MB ram chip with 256MB ram and it solved the problem. What I 
don't know is whether the problem was with the actual memory chip or the size 
of memory (can't think why it would be this). Unfortunately I don't have 
another 128MB chip to find out which!