Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77919

Summary: rpm complains about dependencies that are med
Product: [Retired] Red Hat Linux Reporter: Göran Uddeborg <goeran>
Component: imlibAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: ddumas
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-24 22:42:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Göran Uddeborg 2002-11-15 11:38:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to upgrade from imlib version 1.9.13-2.7.x to version 1.9.13-9 works for
imlib-cfgeditor and imlib-devel.  But when after that trying to upgrade the
imlib package itself, rpm complains that the newly installed imlib-cfgeditor and
imlib-devel needs "imlib = 1.9.13".  As if the new imlib package had some other

Version-Release number of selected component (if applicable):4.1-1.06

How reproducible:

Steps to Reproduce:
1.Start with system with version 1.9.13-2.7.x of the imlib packages.
2.Upgrade first imlib-cfgeditor to 1.9.13-9, and then imlib-devel
  uebn> rpm -q imlib imlib-devel imlib-cfgeditor
3.Try to upgrade the main imlib package too
  uebn### env LANG=C rpm -U imlib-1.9.13-9.i386.rpm
  error: Failed dependencies: is needed by (installed) sawfish-0.30.3-1
        imlib = 1.9.13 is needed by (installed) imlib-cfgeditor-1.9.13-9
        imlib = 1.9.13 is needed by (installed) imlib-devel-1.9.13-9

Additional info:
To upgrade cleanly, I of course upgrade sawfish at the same time.  That removes
the complaint about sawfish as expected, but the other two remain.

This could of course be some kind of packaging error in imlib. I can't see what,
so I'm posting this under rpm to begin with.

One detail I've observed is that imlib has an epoch, it provides "imlib =
1:1.9.13-2.7.x", while the subpackages requires only the version.  This seems
slightly suspect, but I'm not sure about the intended behaviour here.  And in
any case, the old imlib-1.9.13-2.7.x also uses an epoch.  So if this would have
been the error, it would have shown already when I installed that package, and
not now when upgrading to the one from RH8.0.

Comment 1 Michael Lee Yohe 2002-11-15 16:17:45 UTC
That's definitely a strange "chicken-or-the-egg" problem you have there. 
Instead of upgrading the editor and development packages - your workaround (at
present) could be to revert back to the older versions and then upgrade all at once.

Comment 2 Jeff Johnson 2002-11-15 17:38:12 UTC
The Requires: in imlib-{cfgeditor,devel} should
be written with an explicit epoch.

Meanwhile, adding imlib-{cfgeditor,devel} to the
same transaction (i.e. just like sawfish) should get
you out of chicken vs. egg.

Off to imlib for Requires: fix ...

Comment 3 Jonathan Blandford 2003-01-24 22:42:22 UTC
The epoch is needed in the Requires tag, fixed in Rawhide.