Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77875

Summary: Choosing Minimal packages breaks anaconda
Product: [Retired] Red Hat Linux Reporter: Need Real Name <croatia>
Component: ksconfigAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-20 18:35:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-14 17:36:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021106
Phoenix/0.4

Description of problem:
If I include only Minimal packages in ks.cfg anaconda bails out with a Python
error message 

How reproducible:
Always

Steps to Reproduce:
Include only this in your ks.cfg

%packages
@Minimal

Installation will fail. I may have even included packages such as DHCP and
similar thing happened :-(.

Comment 1 Jeremy Katz 2002-11-14 23:13:29 UTC
Could you actually attach the traceback you receive?  I do minimal kickstarts
all the time without problems

Comment 2 Wolfgang Ocker 2002-11-20 18:35:18 UTC
[ Network boot with bootnet.img, ks.cfg on floppy. ]

The output of the Kickstart Configurator reads as

  %packages --resolvedeps
  @Minimal

when selecting "Minimal" in the packages selection. Anaconda doesn't know about
that and returns a key error "Minimal" in line 580 of comps.py. I tried "@Base"
and it worked.


Comment 3 Jeremy Katz 2002-11-20 18:47:52 UTC
Minimal isn't a package group found in the comps file.

Comment 4 Wolfgang Ocker 2002-11-20 19:20:55 UTC
Yes, so the problem is with the graphical kickstart configurator here ...

Comment 5 Need Real Name 2002-11-22 20:18:11 UTC
Shouldn't this be reassigned to ksconfig component then ?

Comment 6 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated