Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77866

Summary: Change default PDF viewer?
Product: [Retired] Red Hat Linux Reporter: Michael Lee Yohe <michael>
Component: distributionAssignee: Havoc Pennington <hp>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 79601, 100644    

Description Michael Lee Yohe 2002-11-14 16:04:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I wasn't sure where to file this RFE, but under my Gnome 2.0 panel to select the
PDF Viewer (Red Hat->Graphics->PDF Viewer), the icon opens xpdf instead of the
native Gnome application ggv.  xpdf is a simple PDF viewer - but lacks the
plethora of features that ggv provides (including solid printing support for PDF
documents - and any documents that GhostScript understands how to open).

By happenstance while perusing the Bugzilla database, I stumbled upon ggv
(having completely forgotten about it) - and have been xpdf'ing my PDF files,
"printing" them to a .ps file, and then lpr'ing them to the printer.  Quit a few
manual steps if the user does not realize the existence of a better alternative.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHL8.
2. Navigate through the Red Hat menu under Gnome (probably under KDE's menu too)
3. Red Hat->Graphics->PDF Viewer
	

Actual Results:  xpdf starts

Expected Results:  ggv starts

Additional info:

Comment 1 Miloslav Trmac 2002-12-14 16:20:46 UTC
OTOH, xpdf allows searching for text.
My general impression is that some files look much better in one,
some in the other.

Comment 2 Michael Lee Yohe 2003-08-08 17:44:30 UTC
Since GGV is dropping support for PDF files, this bug is no longer applies.  We
still need to change the default PDF viewer to a Gnome 2 native viewer.  I had
already filed Bug 99339 to include a Gnome 2 native PDF viewer.

*** This bug has been marked as a duplicate of 99339 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.