Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77699

Summary: Adapters found to be in VGA mode on server entry are not supported by the MMIO-only version of this driver.
Product: Red Hat Enterprise Linux 2.1 Reporter: Johan Walles <johan.walles>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: ia64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-15 07:19:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Log from X refusing to start none

Description Johan Walles 2002-11-12 12:40:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
"startx" fails to start X.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in as root
2. type "startx"


Actual Results:  (EE) ATI(0): Adapters found to be in VGA mode on server entry
are not supported by the MMIO-only version of this driver.

Expected Results:  X should have been started.

Additional info:

Will provide full output from X as an attachment.

Comment 1 Johan Walles 2002-11-12 12:42:39 UTC
Created attachment 84604 [details]
Log from X refusing to start

Comment 3 Johan Walles 2002-11-13 07:59:29 UTC
What the X server is telling me *clearly* is that the driver does in fact
support the current adapter but that it is in some sort of state ("VGA mode")
that the driver can not handle.  The conclusion is of course that I have to
somehow put the adapter into a supported state (what?) before starting X. 
Especially since the installer managed to do graphics, and claims to have
successfully configured X, this is the quite obvious meaning of the message.

If this is not the intent of this (undocumented AFAICT, or can you point me to
where I can read about it?) message, it should either be rephrased to say what
it means, documented, or preferrably both.

Other than that, I appreciate your effort to add support for the adapter.


Comment 5 Johan Walles 2002-11-13 11:26:42 UTC
I still fail to see how it can be possible for the installer to run in graphics
mode if the graphics card is unsupported.


Comment 7 Mike A. Harris 2003-03-15 07:19:13 UTC
Closing as NOTABUG since the reason this happens is intention due to
some ia64 whackiness, and is from patches applied specifically by the
request of Hewlett Packard, and supplied by them.