Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77683

Summary: Tar creates empty files in some cases.
Product: [Retired] Red Hat Linux Reporter: Yannick Patois <patois>
Component: tarAssignee: Jeff Johnson <jbj>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-11 23:08:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yannick Patois 2002-11-11 23:08:09 UTC
Description of Problem:
TAR creates empty archive when both an exclude pattern file and an absolute path
to tar is given.

Version-Release number of selected component (if applicable):
1.13.25-4.7.1

How Reproducible:
Always

Steps to Reproduce:
1. mkdir tarbug;cd tarbug; echo "*.o#" | tr '#' '\n' > exclude;touch foo
2. tar cvZ -X exclude -N "20021103 04:25:36" -f tarbug.tgz `pwd`/foo
3. 

Actual Results:
Empty tar file is created.

Expected Results:
Tar file containing 'foo'

Additional Information:
tar-1.13.19-6 does work.

Take this as a SERIOUS issue: many backup system rely on explude pattern file +
backing up absolute paths. Having empty backup is quite nasty.
My backup system just broke on this !

I'm not sure if the -N flag does matter. Didnt checked.

Comment 1 Jeff Johnson 2002-11-12 11:59:49 UTC

*** This bug has been marked as a duplicate of 77243 ***

Comment 2 Yannick Patois 2002-11-12 12:29:53 UTC
Sorry, an accidental reload of the web page resubmited it.