Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77676

Summary: wrong video card detected with disabled on-board card
Product: [Fedora] Fedora Reporter: Tammy Fox <tammy.c.fox>
Component: rhplAssignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: alexl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 77679    
Attachments:
Description Flags
output of ddcprobe
none
output of lspci -v none

Description Tammy Fox 2002-11-11 22:07:40 UTC
On a Dell Dimension 4500S, I disabled the Intel on-board video card and 
added an ATI Radeon 7500 (PCI). ddcprobe lists the Radeon, lspci shows both
cards.

redhat-config-xfree86 will not start, even if I tell it not to use the existing
configuration file, because rhpl.videocard.VideoCardInfo() returns the onboard
card (it only returns the first card in the list from kudzu):

>>> import rhpl.videocard
>>> videocard = rhpl.videocard.VideoCardInfo()
>>> print videocard
primary: 0
vidCards: [<rhpl.videocard.VideoCard instance at 0x81f878c>,
<rhpl.videocard.VideoCard instance at 0x82ce8cc>]
Primary Video Card Info:
device: None
descr : Intel Corp.|82845G/GL [Brookdale-G] Chipset Integrated Graphics Device
server: XFree86
cardManf: None
vidRam: 16384
carddata: {'CHIPSET': 'Intel 845', 'DRIVER': 'i810', 'NAME': 'Intel 845',
'NOCLOCKPROBE': ''}
devID: Intel 845
fbmodes: None
fbbpp: None

Kudzu output:

>>> import kudzu
>>> cards = kudzu.probe (kudzu.CLASS_VIDEO, kudzu.BUS_PCI | kudzu.BUS_SBUS,
kudzu.PROBE_ALL);
>>> print cards
[Desc:           Intel Corp.|82845G/GL [Brookdale-G] Chipset Integrated Graphics
Device
Driver:         Card:Intel 845
Device:         None
, Desc:           ATI|Radeon 7500 QW
Driver:         Card:ATI Radeon 7500
Device:         None

rhpl needs to either return the add-on card if there is a disabled onboard card
or return all cards found so the frontend program can ask the user which to
configure.

Comment 1 Tammy Fox 2002-11-11 22:08:41 UTC
Created attachment 84584 [details]
output of ddcprobe

Comment 2 Tammy Fox 2002-11-11 22:09:20 UTC
Created attachment 84585 [details]
output of lspci -v

Comment 3 Brent Fox 2003-05-21 19:43:00 UTC
I believe that this was fixed during the RHL 9 cycle.  Please reopen if the
behavior has reappeared.

Comment 4 Tammy Fox 2003-09-30 03:24:21 UTC
anaconda writes out the wrong XF86Config file. When the computer reboots, it
allows me to rerun redhat-config-xfree86. redhat-config-xfree86 tried the
disabled on-board card, fails, then tries the Radeon, and succeeds. Is there any
way to get anaconda to use the same behavior?

Comment 5 Brent Fox 2003-12-18 23:00:12 UTC

*** This bug has been marked as a duplicate of 97788 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:50:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.