Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77616

Summary: TB NCHardwareList:288:save
Product: [Retired] Red Hat Linux Reporter: Andrei Rezvov <andrei.rezvov>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-11 10:10:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andrei Rezvov 2002-11-11 00:27:42 UTC
Traceback (innermost last):
  File "/usr/sbin/redhat-config-network", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/redhat-config-network", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/redhat-config-network", line 287, in save
    self.saveHardware()
  File "/usr/sbin/redhat-config-network", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 862dea0>
hw: <netconfpkg.HardwareList.Hardware instance at 853d388>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 854ce00>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 860ead8>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 853d388>]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. simply run redhat-config-network on my system :-(
2.
3.
	

Additional info:

Comment 1 Sybren 2002-11-11 10:10:24 UTC
I have the same bug with a 3Com-card (3C905C-TX):
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 84f8f38>
hw: <netconfpkg.HardwareList.Hardware instance at 84efbf8>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 84eec30>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84b47f0>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 84efbf8>]

The card is shown in lsmod.
The only thing I can imagine is that there is something wrong with the IRQ#: it 
is the same as the video-card.
I have not been able to get my NIC working, trying for weeks now and getting 
frustrated. In Windows 98 the NIC is working without any troubles.
I have tried to influence the IRQ# with 3c905cfg.exe but that program tells me 
the IRQ# cannot be changed.

Sybren

Comment 2 Harald Hoyer 2002-11-11 10:17:41 UTC
second beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.2-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.2 version... Thx
and please test.

*** This bug has been marked as a duplicate of 74417 ***