Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77566

Summary: anaconda crashes on change disk dialog
Product: [Retired] Red Hat Linux Reporter: Need Real Name <fsmds>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-16 11:19:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-09 11:32:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
When installing Redhat8.0 on a Sony Picturebook PCG-C1MV, the installer
(anaconda) will crash if it attempts to install RPMS from the second disk. 
After several(five or six) tries, I finally got an install which did not require
anything on the second disk, and it installed flawlessly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.anaconda starts to install the rpm files from cdrom
2.process goes fine until time to switch disks
3.when rpm is encountered that is on second cd, anaconda crashes
	

Actual Results:  anaconda crashed, dropping me back to shell, and rebooting the
system.

Expected Results:  A dialog should have appeared asking me to switch to disk 2

Additional info:

The bug was encountered no matter how the computer was configured, how the
partition table was created (ie automatic or by hand) or what computer type you
picked(desktop, workstation server)

Comment 1 Michael Fulbright 2002-11-11 15:40:41 UTC
Have you tested your media?

http://rhlinux.redhat.com/anaconda/mediacheck.html

Comment 2 Need Real Name 2002-11-16 11:18:57 UTC
Yes, I checked all of the cds, they all passed.
finally, here is the error message:

Traceback( most recent call last):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 149 in renderCallback
  self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 719, in doinstall
  problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb, cb, 0)
File "/usr/lib/anaconda/packages.py", line 283, in cb
  fn = self.method.getFilename(h, self.pkgTimer)
File "/usr/lib/anaconda/image.py", line 119, in getFilename
  f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'


There is a diskspace error, however, after installing a bare-bones system,
booting and then installing the rest of the system from within linux, I had no
problems, and even now, after installing pretty much everything in sight, my
disks are all below 40% usage... One possible problem with this particular
computer is the 112 MB of ram, but I wouldn't think that would be a problem..

Comment 3 Michael Fulbright 2002-11-19 20:13:01 UTC

*** This bug has been marked as a duplicate of 75377 ***