Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77408

Summary: red error markers at warnings
Product: [Retired] Red Hat Developer Suite Reporter: Need Real Name <ahussain>
Component: eclipseAssignee: eclipse-bugs
Status: CLOSED CURRENTRELEASE QA Contact: eclipse-bugs
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-07-24 21:58:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2002-11-06 17:25:22 UTC
Description of Problem:

When building a project that produces warnings on the console, although the
project is built and an executable is made, red error markers appear on the file
tab, project and file in the C/C++ projects view and line location of the
warning. I thought a red marker on a project name implies it has not been
built.Even the tasks view shows errors corresponding to the warnings, not
warnings. These markers should be yellow exclamations instead, corresponding to
how Eclipse represents warnings. 

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. create a standard Make C project
2. create a Makefile and a .c file which doesn't have a newline as the last line
of the file. 
3. building gives the warning "file.c:...:warning: no newline at end of file"

Actual Results: 
red error markers on project, file, file tab and warning location in file.

Expected Results:
should be yellow warning markers

Additional Information:

Comment 1 Jeremy Handcock 2003-07-24 21:58:56 UTC
This has since been fixed.  Closing.