Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77403

Summary: graphical rpm installer does strange things
Product: [Retired] Red Hat Linux Reporter: Need Real Name <jbeach>
Component: redhat-config-packagesAssignee: Jeremy Katz <katzj>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: ctalk
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-10 01:53:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-11-06 15:07:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020830

Description of problem:
I'm not sure that I have this bug under the correct package. I have used the new
graphical package manager in RH8 several times, and it behaves very erratically.
The first time, after a new install, I used it to install abiword and gnumeric.
Afterward, they were there but now OpenOffice was gone. This happened twice on
two different computers. Another example: I have GNOME installed. Sometimes when
I go to install other software, the package manager says that none of GNOME is
currently installed, or parts are missing. If I do nothing with the GNOME
checkboxes and install the other software, sometimes I end up with GNOME
packages missing. This can be fixed by re-running the pacakge manager and
selecting all of the GNOME components. The problem is, then I worry about what
else is going to get hosed. I use CUPS instead of LPRng, and I have also had
trouble with CUPS getting messed up and LPRng reinstalled when I run the package
manager for something else. 

In a nutshell, the package manager seems unable to keep track of what really is
installed and what is supposed to be removed. At this point, I avoid using it,
and just use rpm at the command line if I know what specific packages need to be
installed or removed. I've had no trouble with that.  

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Run the 'Packages' program from the 'System Settings' menu
2.Examine what packages the program says are installed
3.Pick a package to install
	

Actual Results:  The listed packages are sometimes different from what you KNOW
are installed. For example, you are using GNOME, but it says GNOME is not
installed. Installing a packages sometimes results in the removal of other
packages that were not selected for removal

Expected Results:  The package list should accurately identify what packages are
installed, and should only remove or install packages that you select/deselect. 

Additional info:

Comment 1 Jeremy Katz 2002-12-31 07:35:54 UTC
I haven't seen this or any other reports of it.

Can you give exact steps to reproduce the problem you're seeing?

Comment 2 Jeremy Katz 2003-02-10 01:53:21 UTC
Closing due to lack of activity.