Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77396

Summary: __libc_sigaction, version GLIBC_2.2 not defined
Product: [Retired] Red Hat Linux Reporter: christophe chevance <christophe.chevance>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: fweimer
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-06 12:30:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description christophe chevance 2002-11-06 12:29:55 UTC
Description of Problem:

When trying to use the program "fasta" from bioinformatics Accelrys GCG package  
I got a relocation error :

relocation error: ./fasta: symbol __libc_sigaction, version GLIBC_2.2 not
defined in file libc.so.6 with link time reference

Version-Release number of selected component (if applicable):
the last for GCG
glibc is 2.2.5-40

How Reproducible:
Always

Steps to Reproduce:
1.get fasta program from GCG package
 
2. run it :
   ./fasta
      
3. see result
 

Actual Results:
./fasta: relocation error: ./fasta: symbol __libc_sigaction, version GLIBC_2.2
not defined in file libc.so.6 with link time reference

Expected Results: 
Should be on unconfigured host :
 Configuration error.  Unable to open "GenCoreRoot:gcgcore/account/configure.txt".
Configuration problem: can't find GCGBASEROOT
Contact your system manager.

Additional Information:	
This binary works OK with all others 7.x RedHat Linux

The problem seem to come from glibc :
on RedHat 7.2
$ readelf -s  libc.so.6 |grep __libc_sigaction
    67: 0002ea14   306 FUNC    GLOBAL DEFAULT   11 __libc_sigaction@@GLIBC_2.2

on redHat 7.3
$ readelf -s  libc.so.6 |grep __libc_sigaction
    65: 000291e4   289 FUNC    GLOBAL DEFAULT   11 __libc_sigaction@@GLIBC_PRIVATE

and not expected GLIBC_2.2

Comment 1 Jakub Jelinek 2002-11-06 12:41:50 UTC
__libc_sigaction always used to be a glibc private symbol, never declared in
any headers nor intended for anything but libpthread. Recent glibc's use symbol
versioning to make it clear what is and what is not a private interface.
fasta needs to be fixed to avoid using internal interfaces which can be removed
or changed at any time.