Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77295

Summary: incorrect error message
Product: [Retired] Red Hat Linux Reporter: Chris Ricker <chris.ricker>
Component: vorbis-toolsAssignee: Colin Walters <walters>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-05-13 20:06:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Chris Ricker 2002-11-04 19:20:04 UTC
Running oggenc with the -b option (to specify bitrate) and forgetting the
bitrate results in a bogus error message.  Rather than something like:

ERROR:  No bitrate specified.  Use -h for help.

it responds with an incorrect "No input files specified".  For example:

[kaboom@verdande wav]$ oggenc -b 10_exit.wav 
OggEnc v1.0 (libvorbis 1.0)
(c) 2000-2002 Michael Smith <msmith@labyrinth.net.au>

ERROR: No input files specified. Use -h for help.
[kaboom@verdande wav]$ 

Compare that with the correct command line, below:

[kaboom@verdande wav]$ oggenc -b 320 10_exit.wav 
Opening with wav module: WAV file reader
Encoding "10_exit.wav" to 
         "10_exit.ogg" 
at approximate bitrate 320 kbps (VBR encoding enabled)
        [100.0%] [ 0m00s remaining] \

<snip>

it's the bitrate that's missing, not the input file....

Comment 1 Colin Walters 2004-05-13 20:06:39 UTC
A warning is now output that the specified bitrate is not recognized,
e.g.:

walters@nexus> oggenc -b /usr/share/sounds/question.wav              
                  /src/work/rpms/vorbis-tools
Warning: nominal bitrate "/usr/share/sounds/question.wav" not recognised
OggEnc v1.0.1 (libvorbis 1.0.1)
(c) 2000-2003 Michael Smith <msmith@xiph.org>
 
ERROR: No input files specified. Use -h for help.