Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77233

Summary: Cross compile support in glibc
Product: [Retired] Red Hat Raw Hide Reporter: hjl
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: fweimer
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-28 06:34:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
A patch not to use LD none

Description hjl 2002-11-03 22:30:57 UTC
RedHat glibc has

$(LD) -r -o $@ $^

It is not very friendly to cross compile.

Comment 1 hjl 2002-11-03 22:31:38 UTC
Created attachment 83368 [details]
A patch not to use LD

Comment 2 Jakub Jelinek 2002-11-10 20:26:18 UTC
Added to my tree.

Comment 3 Ulrich Drepper 2004-09-28 06:34:39 UTC
Closing since a) cross-compiling is nothing we care about for the
SRPM, and b) if Jakub made a change it's long in the sources.