Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 772

Summary: SB16 not recognized
Product: [Retired] Red Hat Linux Reporter: yarbrough
Component: sndconfigAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-11 15:28:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description yarbrough 1999-01-10 06:39:05 UTC
SB16 (not PnP) is no longer auto detected by sndconfig.
Pretty sure it worked with RH 5.1.  Even manually setting
IRQ, DMA & I/O info doesn't work. Fails sample sound.

Comment 1 yarbrough 1999-01-10 20:36:59 UTC
Got it working by adding the following two lines to /etc/conf.modules

alias sound sb
options -k sb io=0x220 irq=5 dma=1,5

Why didn't this get added during setup?

Comment 2 Bill Nottingham 1999-01-11 15:28:59 UTC
if you got the error message
'An error occured opening /dev/audio', you hit a bug in
sndconfig. It's been fixed since RH5.2 was released.

Comment 3 tincher 1999-03-25 03:31:59 UTC
You also need to add:
alias midi opl3
options -k opl3 io=0x388