Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77188

Summary: Installer crashes with message " OSError:(Errno 12)"
Product: [Retired] Red Hat Linux Reporter: Ingvald Ramsrud <iramsrud>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: michael, reed
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-11 15:57:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ingvald Ramsrud 2002-11-02 16:54:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; 
SC/5.07/1.00/Compaq)

Description of problem:
Installer crashes every time with message "OSError (Errno 12) Kan ikke tildele 
minne." I am installing RedHat Linux 8.0 on a P166, 64Mb ram, and 40 Gb HD. The 
machine used to run Win ME with no problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start setup
2.Norwegian keyboard
3.
	

Actual Results:  Crash!

Expected Results:  Install completed...

Additional info:

Comment 1 Michael Fulbright 2002-11-04 22:24:49 UTC
Was this a graphical or text mode install?

What did you select to install?

Comment 2 Ingvald Ramsrud 2002-11-06 17:58:36 UTC
Hello, and thank you for your reply.

Additional info as requested:

* Install was in Graphical mode

* Partitioning was automatic

* Install selected was Personal Desktop

* Chosen packages was GNOME, OpenOffice, Mozzilla, Evolution, Instant Messging,
  Sound and picture-program and Games. All as recommended.

Here is the complete list of errors:
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
self.currentWindow.renderCallback()
File "usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
self.intf.icw.nextClicked()
File"/usr/lib/anaconda/gui.py", line 632, in nextClicked
self.dispatch.gotoNext()
File"usr/lib/anaconda/dispatch.py",line 150, in gotoNext
self.moveStep()
File"usr/lib/anaconda/dispatch.py" line 215, in moveStep
rc=apply(func,self.bindArgs(args))
File"/usr/lib/anaconda/packages.py" line 430, in turnOnFilesystems
partitions.doMetaDeletes(diskset)
File"/sr/lib/anaconda/partitions.py" line1110, in doMetaDeletes
lvm.vgactivate()
File"/sr/lib/anaconda/lvm.py" line 54, in vgactivate
searchPath=1
File"/usr/lib/anaconda/iutil.py" line 66, in execWithRedirect
childpid=os.fork()
OSError: (Errno12) kan ikke tildele minne



Comment 3 Need Real Name 2002-11-09 09:54:46 UTC
I got the exact error with the same traceback path except I chose English and 
the last line said:
OSError:[Errno 12] Cannot allocate memory

Comment 4 Michael Fulbright 2002-11-11 15:57:15 UTC
Please try in text mode - that will require less memory.

Comment 5 Ingvald Ramsrud 2002-11-12 20:31:15 UTC
Install in text mode OK.
Linux is now running fine, but a little slow. Will try to buy some more memory!

Comment 6 Michael Lee Yohe 2003-01-09 14:08:43 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.