Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77156

Summary: users with special caracters in username make group identification problems
Product: [Retired] Red Hat Linux Reporter: Tarhon-Onu Victor <lsmituc>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: fweimer
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tarhon-Onu Victor 2002-11-01 21:09:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
When adding more than 64 users and assingning them to the same group, that group
will be not visible anymore, nor the groups listed after that group in /etc/group.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. for i in $(seq 1 70); do useradd -m -g users user-user$i; done;
2. for i in $(seq 1 70); do echo -n $i.\  ; gpasswd -a user-user$i disk; done;
3. id apache
	

Actual Results:  The output of the command "id apache" will show us the username
associated to the uid 48, but will NOT show us the groupname associated to gid
48. id user-user3 will have similar results.

Additional info:

I could not reproduce this with glibc 2.2.5-xx. I haven't tested it yet with
2.2.90, only with 2.2.93-3 and 2.2.93-5.

This bug, when affecting groups like 'users', 'wheel', etc, will cause lots of
daemons not to start (apache, mysql, and any daemon running as different user
than root, havind group listes after the affected group in /etc/group). This is
ugly.

Comment 1 Jakub Jelinek 2002-11-10 20:28:52 UTC
Please try glibc-2.3.1-{5,6} from rawhide.

Comment 2 Alan Cox 2002-12-16 01:58:17 UTC

*** This bug has been marked as a duplicate of 76531 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.