Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77092

Summary: redhat-config-network dies when left open too long
Product: [Retired] Red Hat Linux Reporter: bjl
Component: rhplAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-01 02:23:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bjl 2002-11-01 02:23:05 UTC
Description of Problem:
The "redhat-config-network" utility will crash when left open for an extended
period of time.  The given error is "too many open files".  Network connectivity
is unaffected.

Version-Release number of selected component (if applicable):
1.1.20-1

How Reproducible:
Open "redhat-config-network".  Leave it open for approximately 45-60 minutes. 
Eventually the application will crash.

There's probably a file.close() call missing in the Python code, somewhere.

Comment 1 Harald Hoyer 2002-11-04 12:46:03 UTC
fixed in >= rhpl-0.54-1
there will be a bugfix errata

*** This bug has been marked as a duplicate of 74989 ***