Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 77003

Summary: ks hd install fails when RedHat Directory on "/"
Product: [Retired] Red Hat Linux Reporter: P Jones <bugzilla>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: high    
Version: 7.3CC: pp
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-05 02:59:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description P Jones 2002-10-30 20:16:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
installer gives error "Requested Partiiton Does Not Exist", partition exists

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. partition hda1 to 5G
2. copy cd's to /rhsource
3. start install, using kicstart below
	

Additional info:

The last message on tty3 is "* hda1 is a protected partition"

Here's the kickstart file:
install
text
lang English
langsupport     English
keyboard us
mouse generic3ps/2 --device psaux --emulthree
rootpw password
firewall --medium
authconfig --enableshadow --enablemd5
bootloader
network --bootproto dhcp
part / --fstype ext2 --noformat --onpart hdc2
harddrive --partition hdc1 --dir /rhsource
%packages
@ Base


I'm using the kernel and initrd-everything.img from /images/pxeboot/
I'm passing the arguement "ks=hd:hda1/kickstart" to the installer.
It is finding the second stage.

Comment 1 P Jones 2002-10-31 03:04:50 UTC
I also tried copying the .iso files to the /rhsource directory.  I did find
those files, but errored with the same message

Comment 2 P Jones 2002-10-31 03:06:18 UTC
oh, and the iso mediacheck passes, and can install fine if located on a diffrent
partition. (one not marked for use in the ks file with a "part" line)

Comment 3 P Jones 2002-10-31 16:17:42 UTC
Corrections: 
I tired this on hda as well as hdc; I put hda in steps to reproduce, I ment to
be consistant with the kickstart file posted. Please assume I ment hdc.

The kickstart pasted was the one that worked, to get the one that failed,
replace the part line with this:
part / --fstype ext2 --noformat --onpart hdc1

Comment 4 Michael Fulbright 2003-01-31 19:13:14 UTC
This currently fails when trying to mount the harddrive images to merge the RPM
headers.

To correct this problem will require some special case code that recognizes when
the source for the harddrive install images is also a partition used for the
installed system.


Comment 5 Michael Fulbright 2003-05-06 21:02:52 UTC
This affects installs and upgrades.

Comment 6 Michael Fulbright 2003-05-12 18:44:27 UTC
*** Bug 90599 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2004-10-05 02:59:42 UTC
This should be happier in newer releases.