Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76954

Summary: rm fails to remove symbolic links
Product: [Retired] Red Hat Linux Reporter: Steve Bonneville <sbonnevi>
Component: fileutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED NOTABUG QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: high    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-30 12:58:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Steve Bonneville 2002-10-30 02:20:03 UTC
Description of Problem:

  The rm command will not remove symlinks properly.  Behavior is different
  on ext2 and ext3 filesystems, but broken both places.
    On ext2, symlinks may not be removed at all.
    On ext3, symlinks to directories may not be removed.
  Worked fine in 7.3 with fileutils-4.1-10.

Version-Release number of selected component (if applicable):

  fileutils-4.1.9-11

Steps to Reproduce:

1. touch testfile; ln -s testfile linkfile
2. touch testdir; ln -s testdir linkdir
3. rm linkfile linkdir

Actual Results:
  rm: cannot remove `linkfile/': Not a directory.
  rm: cannot remove `linkdir/': Not a directory.

Expected Results:
  The symlinks "linkfile" and "linkdir" should be deleted.
  The file "testfile" and directory "testdir" should still exist.

Comment 1 Leonid Mamtchenkov 2002-10-30 12:58:53 UTC
First of all, you probably mistyped mkdir with touch in the second step, since
touch does not create directories, afaik.  Secondly, you try to remove the file
like a directory, i.e. with a slash at the end.  This gives the first error. 
Thirdly, since your linkdir is actually a file and not a directory, you get the
same error as above.

I have tried to reproduce the problem you are describing, and could not.  rm
works fine for me. :)