Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76931

Summary: references to rhn_register
Product: Red Hat Network Reporter: bill parducci <bill>
Component: RHN/BackendAssignee: Mihai Ibanescu <mihai.ibanescu>
Status: CLOSED RAWHIDE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN StableCC: gafton, mihai.ibanescu, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-21 16:40:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description bill parducci 2002-10-29 17:10:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

Description of problem:
i had a corrupt systemid file and up2date (rhn_check, etc.) kept telling me that
my certifcate wa corrupt and to rerrun rhn_rgister to regen. well, as i found
out (painfully) rhn_rerister no longer exists. the solution to the problem is to
DELETE the /etc/syconfig/rhn/systemid and rerun up2date (et al.)

DOCS & error messages shold reflect this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. fire up vi
2. do a simple edit on /etc/syconfig/rhn/systemid
3. run up2date or rhn_check
	

Actual Results:  # rhn_check -v
Could not retrieve action item from server <Server for www.rhns.redhat.com/XMLRPC>
Error code: -9
Error Message:
    Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid Server Certificate.


Expected Results:  [...]

Error Message:
    Please delete /etc/syconfig/rhn/systemid and rerun as root on this client

Additional info:

# uname -a
Linux deedee 2.4.18-17.8.0smp #1 SMP Tue Oct 8 12:39:01 EDT 2002 i686 i686 i386
GNU/Linux

Comment 1 Adrian Likins 2002-11-04 21:43:18 UTC
This error message comes from the server, so reassigning as a server
side bug.

Comment 2 Jay Turner 2002-11-21 17:30:17 UTC
Closing out.  Working correctly in the webqa environment.