Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76902

Summary: Add Macedonian keyboard
Product: [Retired] Red Hat Linux Reporter: Zlatko Trajceski <zlat>
Component: rhplAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-15 19:37:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Zlatko Trajceski 2002-10-29 01:15:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
Please add the Macedonian keyboard to the 
/usr/lib/python2.2/site-packages/rhpl/keyboard_models.py
with the following options:
  'mk'                      : ['Macedonian', 'mk', 'pc104', ''],

But there's a problem with this setting so please I need a help here. 

This setting defines also a console keyboard and in this case it's a mk keyboard
which is iso-8859-5, but that's wrong keyboard since in RH 8.0 utf8 is the
default encoding the right keyboard is mk-utf. 
So the mk (iso5) keyborad is wrong setting and mk-utf is correct one, but this
tool insist the X and console keyboard to have the same name. Any solution to this?

Problem 2 is that XKB Macedonian keyboard needs:
Option      "XkbOptions" "grp:alt_shift_toggle"
Any idea how can I specify for that to be included in XF86Config when I select
the Macedonian keyboard in redhat-config-keyboard?

Thanks a lot in advance.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just log in :_)
2.
3.
	

Additional info:

Comment 1 Zlatko Trajceski 2002-10-29 02:12:19 UTC
I just sow there's a solution for the first problem (the console utf keymap) so
the correct line is:

  'mk-utf'                      : ['Macedonian', 'mk', 'pc104', ''],


But the second problem with including:
  Option      "XkbOptions" "grp:alt_shift_toggle"
in XF86Config still exists.


Comment 2 Jeremy Katz 2002-10-31 22:58:44 UTC
Added layout to CVS.

Brent -- we currently don't have a way to represent options which need to be
added in the keyboard model dict.  Interested in adding to
redhat-config-keyboard (and thus have it used by anaconda, etc)?

Comment 3 Brent Fox 2002-11-15 19:36:56 UTC
Hmm, I really want to keep this UI as simple as possible.  If the Macedonian
keyboards always need this option set, doesn't it make more sense to have the
Macedonian X keymap enable this by default instead of having to work around it
in the XF86Config file?

Comment 4 Brent Fox 2002-12-11 16:10:05 UTC
I think the keyboard tool is the wrong place to fix this.  If the Macedonian
keymap always needs 
"Option      "XkbOptions" "grp:alt_shift_toggle"
then it seems like the keymap should be fixed to always have this set by
default.  Please file a new bug against XFree86.

I'm going to close this report as "rawhide" since katzj has added the Macedonian
keymap to the keyboard model list.