Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76887

Summary: Gnome-font problem in KDE
Product: [Retired] Red Hat Linux Reporter: Need Real Name <reivec>
Component: kdebaseAssignee: Petr Rockai <prockai>
Status: CLOSED CANTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: rickg, t.hartwig
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-18 18:26:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2002-10-28 19:14:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
First off if you change your gnome fonts and load KDE instead, your font settings are not loaded.. then if from KDE you run gnome-font-properties to change it (since KDE users will probably want to unify there appearence as much as possible) it will show the proper font selection and update all the fonts as soon as it loads, BUT at the same time is totally kills the KDE desktop and all keyboard shortcuts.  So basically the only way I am aware of to load the proper gnome fonts will kill KDE components, and I would have to run that everytime I load KDE, which is annoying.  Gnome fonts need to work properly while in KDE and vise versa to keep a uniform appearence.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load KDE
2. Run gnome-font-properties
3.
	

Actual Results:  kills KDE desktop components	

Expected Results:  Not killing stuff 8P

Additional info:

That should do ya

Comment 1 Havoc Pennington 2002-10-28 19:22:09 UTC
Running gnome-font-properties in KDE isn't intended to work really (that's why
it isn't in the menus under KDE). What should happen is that GTK 2 apps pick up the 
font set in your KDE control panels.

Comment 2 Owen Taylor 2003-01-09 20:11:22 UTC
*** Bug 79359 has been marked as a duplicate of this bug. ***

Comment 3 Matthias Clasen 2004-05-20 14:25:39 UTC
The real fix for this would be to add xsettings support to kde, at
least make the kde control center export its settings as xsettings, so
that gtk+ apps can pick them up. I don't know 

a) if there's much interest in that upstream
b) how much work that would be
c) if anybody besides Owen would be up to it

Comment 4 Petr Rockai 2006-07-17 18:28:11 UTC
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.

Comment 5 Bill Nottingham 2006-10-18 18:26:42 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.