Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76854

Summary: Sources: cannot build procmail because make comes to infinite loop
Product: [Retired] Red Hat Linux Reporter: Sysoltsev Slawa <vyatcheslav.sysoltsev>
Component: procmailAssignee: Jens Petersen <petersen>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-20 13:10:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Log received from command `rpm -bb procmail.spec --rcfile ../rpmrc` (custom rc file is like system but with pathes to local directory) none

Description Sysoltsev Slawa 2002-10-28 10:19:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When I trying to build procmail from SRPM package I experience such failure:

/bin/sh ./initmake /bin/sh "/bin/sh" "/bin/rm -f" "mv -f" "ln" \
 "-lm -ldir -lx -lsocket -lnet -linet -lnsl_s -lnsl_i -lnsl -lsun -lgen -
lsockdns -ldl" \
 "/lib /usr/lib /usr/local/lib" \
 /dev/null "make" o \
 "cc" "-O2 -march=i386 -mcpu=i686  " "  " "procmail lockfile formail mailstat" \
 "procmail formail lockfile" \
 "procmailrc procmailsc procmailex" "src man" \
 "/usr/bin" \
 "strip"
/bin/sh: /dev/null: Too many open files in system
Warning: your /bin/sh has noclobber turned on, avoiding it
***************************** WARNING *********************************
* You seem to have set the LD_LIBRARY_PATH variable, this might cause *
* some trouble during the compilation of this package.  If the make   *
* does not finish by itself, do a: "make clean", clear                *
* LD_LIBRARY_PATH from the environment, and start over.               *
***************************** WARNING *********************************
Whoeaaa!  There's something fishy going on here.
You have a look and see if you detect anything uncanny:
*******************************************************
cat: _autotst.rrr: Too many open files in system
*******************************************************
I suggest you take a look at the definition of CFLAGS* and CC
in the Makefile before you try make again.
make[2843]: *** [init] Error 1
make[2843]: Leaving directory `/users/compiler/tmp/rtt/WORK_DIR/BUILD/procmail-
3.22'
make[2842]: *** [man/Makefile] Error 2
make[2842]: Leaving directory `/users/compiler/tmp/rtt/WORK_DIR/BUILD/procmail-
3.22'
make[2841]: *** [man/Makefile] Error 2

As you see there is system overflow when 'make' call yourself 2842 times. I've 
tried to investigated why it happens, but your 'make init' script is too 
tricky. Being called from Makefile it tries to substitute same Makefile and 
after it something have to gone further. But it doesn't succeed for some 
unknown reason and 'make' repeats 'make init' endlessly. Could you leave 
trickiness and develop something more stabile ??

Sometimes (very rarely definitely and only in the past) build succeeded, but 
most time I try now it fails.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Try to build source rpm.


Actual Results:  Infinite recursion while doing 'make init' until system 
resources are over. Build time error as a result.

Expected Results:  Succesfully built package.

Additional info:
procmail I've tried to build:
procmail-3.22-5.src.rpm

Here is system component's versions:
kernel-2.4.18-10smp
glibc-2.2.5-34
make-3.79.1-8

Feel free to ask more what is needed..

Comment 1 Jens Petersen 2002-11-11 06:24:07 UTC
Could you add the complete build log for me as an attachment (preferably in
unix text format)? (It's kinda hard to see what is going on from the above.)

procmail-3.22-7 rebuilds fine on my 7.3 box.

Comment 2 Sysoltsev Slawa 2002-11-12 15:15:03 UTC
Created attachment 84644 [details]
Log received from command `rpm -bb procmail.spec --rcfile ../rpmrc` (custom rc file is like system but with pathes to local directory)

Comment 3 Jens Petersen 2003-02-19 14:30:02 UTC
Are you using "icc"?  See also bug 58095.

Comment 4 Sysoltsev Slawa 2003-02-19 14:35:54 UTC
No. Bug was got using gcc.

Comment 5 Sysoltsev Slawa 2003-02-19 14:39:29 UTC
By the way I am using RH8.0 now. Described problems wasn't observed there, so 
this tracker is obsolete and can be closed.

Comment 6 Jens Petersen 2003-02-20 13:10:34 UTC
Ok, thanks for the update.