Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76832

Summary: NEEDINFO mount fat32 -w
Product: [Retired] Red Hat Linux Reporter: Dan Clowater <danclowater>
Component: mountAssignee: Elliot Lee <sopwith>
Status: CLOSED WORKSFORME QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-07-07 16:04:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dan Clowater 2002-10-27 20:06:58 UTC
Description of Problem:
unable to mount windows fat 32 via fstab rw.  I can mount the volumes rw for
root only, and only when I mount manually. using the string:

mount -w -t vfat /dev/hda1 //mnt/cee

tried using -o gid=500 and a whole wrath of variations - yet I still cannot get
the volumes to load rw for my primary login - so I don't have to login as root.

also tried adding to the fstab - but that fails on bootup - it starts to mount
the volumes then hangs and I have to ctrl+c past it.

Version-Release number of selected component (if applicable)
kernel 2.4.18-17.8.0

How Reproducible:
whenever I try to mount windows volumes rw for all users

Steps to Reproduce:
1. mount in fstab - fails
2. manual mount only makes rw to root - despite options

Actual Results:

no re for my admin login
Expected Results:

rw for admin login
Additional Information:
suggestions PLEASE!!! :)

Comment 1 Elliot Lee 2002-10-29 11:55:35 UTC
My wild-and-uninformed guess is a configuration error, since it "WORKSFORME". I can't 
help you track down that type of problem, but if you use one of the support forums 
mentioned on our web site to narrow things down to the actual cause of things, and use 
that info to make up a reproducible test case, I'll be happy to look at the problem then.