Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76821

Summary: Bzip2 mime type not recognized by file
Product: [Retired] Red Hat Linux Reporter: Paul Carter <pacman128>
Component: fileAssignee: Jeff Johnson <jbj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-27 14:48:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Carter 2002-10-27 14:48:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When using "file -i" on a bzip2 compressed file, it returns back "data" and not
"application/x-bzip2" as expected and as RH 7.2 would do. A grep of
/usr/share/magic.mime finds that "application/x-bzip2" does not appear in the file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type "file -i access_log_2002_09.bz2"

	

Actual Results:  file: Using regular magic file `/usr/share/magic.mime'
access_log_2002_09.bz2: data


Expected Results:  file: Using regular magic file `/usr/share/magic.mime'
access_log_2002_09.bz2: application/x-bzip2

Additional info:

Comment 1 Jeff Johnson 2002-10-27 16:14:19 UTC

*** This bug has been marked as a duplicate of 14741 ***