Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76805

Summary: cups doesn't send PJL when printing PCL file
Product: [Fedora] Fedora Reporter: Jonathan Kamens <jik>
Component: cupsAssignee: Tim Waugh <twaugh>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: p.van.egdom, triage
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-06 23:55:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 235704    

Description Jonathan Kamens 2002-10-26 23:52:55 UTC
If I generate a PCL file and print it with "lpr", it gets sent to the printer
without the PJL wrapper setting such things as print density, economy mode, etc.
 In contrast, if I print a text file which is converted to postscript
automatically, the PJL for the printer driver settings I've specified are
correctly sent to the printer.  I haven't tried what happens if I print a
PostScript file.

I'm using a laserjet 1100 with the ljet4 driver.  I've got cups-1.1.15-12 and

The bug here is that PCL files should be correctly wrapped in PJL; only a file
already containing PJL should be left completely unmodified.

Comment 1 giulioo 2002-10-29 13:44:22 UTC
I think this is by design, since PCL is autotyped as cups-raw

application/vnd.cups-raw    (string(0,<1B>E) + !string(2,<1B>%0B)) \ ...
<ESC>E is PCL reset

so it's sent to the printer as is, raw.

The PCL file might include other settings (using PCL escapes) for density,
economy, ... so adding PJL could produce unpredictable results, I think.

Comment 2 Jonathan Kamens 2002-10-29 14:28:42 UTC
If it's by design, then I think the design is wrong.

If the PCL contains settings, then they'll override the PJL settings.  That's
not unpredictable, it's correct behavior.

Note, furthermore, that since I believe CUPS actually saves the PJL parameters
that it sends with each job (i.e., I believe it writes the parameters at the
start of the job into the printers persistent configuration rather than making
them for just that job), the *current* behavior is unpredictable -- the exact
format (economy mode, density, etc.) in which a PCL job prints depends on the
format of the last job sent to the printer (i.e., the settings used to print the
last job).

Comment 3 giulioo 2002-10-29 15:42:01 UTC
For the design issue you can try asking cups developer, who is usually very

For the PJL, I tried looking at the PJL produced by cups own drivers, but could
not find quickly a driver that does it.
Foomatic PJL seems fine, since it does (ie for a hl1250):
and not 

Comment 4 Tim Waugh 2002-12-12 15:57:12 UTC
So are there any drivers that do the wrong thing?

Comment 5 Bill Nottingham 2006-08-08 02:00:13 UTC
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.

Comment 6 Bill Nottingham 2006-10-18 19:40:34 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Closing as CANTFIX.

Comment 7 Jonathan Kamens 2006-11-26 19:03:27 UTC
This is still a problem in Fedora Core.

Comment 8 Peter van Egdom 2007-07-02 21:25:47 UTC
Reassigning bug to product "Fedora" to keep tracking it.

Comment 9 Bug Zapper 2008-04-03 15:25:46 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 10 Bug Zapper 2008-05-06 23:55:11 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here: