Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76774

Summary: Bad unicode breaks nautilus open application
Product: [Retired] Red Hat Linux Reporter: Need Real Name <sam>
Component: nautilusAssignee: Alexander Larsson <alexl>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: alexl, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-12 13:05:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Tar of file with "bad unicode" name that crashes nautilus eventually none

Description Need Real Name 2002-10-26 10:00:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I had a filename with bad unicode (from vfat partition).  Once a nautilus window
on the directory containing this bad filename, then doubleclicking on ANY
openoffice document ANYWHERE to open the document caused nautilus to consume all
memory and swap and then crash and restart.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a filename with bad unicide (nautilus will report (Invalid Unicode)
below the filename.  My filename had character 0xD0 as one charater
2. Use nautilus to navigate to the directory containing this bad file
3. Double click on any open Office document anywhere (even on the deskto)
4. Watch nautilus die
5. All is well again until that folder is shown by nautilus again
	

Actual Results:  Nautilus crashes consuming all memory when opening ocuments

Expected Results:  Nothing much

Additional info:

Comment 1 Havoc Pennington 2002-10-26 15:07:17 UTC
Can you get us the exact filename?

I'm not thinking of a _great_ way to upload the filename; you could make a tar 
archive of the single file, but that would include the file contents.
Maybe just "echo filename > foo.txt" and attach foo.txt would work, 
maybe instead of typing "filename" type the first letter and push tab so 
the shell escapes it for you, if it contains chars the shell doesn't like.

Thanks!

Comment 2 Need Real Name 2002-10-28 08:40:17 UTC
Created attachment 82344 [details]
Tar of file with "bad unicode" name that crashes nautilus eventually

Comment 3 Alexander Larsson 2002-11-05 09:41:21 UTC
Very strange. I can repeat this every time with the RH8 nautilus, but it crashes
in very strange places. It seen to often be in __errno_location in libc (which
reads thread local storage). I also saw it once in __pthread_alt_lock. This
seems to point to a thread issue of some sort.

I also reproduced it by launching gedit on a text file. OOo is not required.

Unfortunately this doesn't happen at all in my gnome cvs build, which means
either it was fixed, or the different build is hiding the issue.

Comment 4 Alexander Larsson 2002-11-05 10:02:17 UTC
Tried to valgrind it, but ran out of memory :/


Comment 5 Alexander Larsson 2003-01-16 14:35:46 UTC
I can't seem to reproduce it on phoebe. Maybe it's fixed.


Comment 6 Alexander Larsson 2003-08-12 13:05:01 UTC
Marking this fixed, since we haven't seen any dups since then.