Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76770

Summary: Can not build modules for parport, lp, and ppa setting parameters for modules as part of xconfig
Product: [Retired] Red Hat Linux Reporter: Harry Gold <hgold>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-31 17:32:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Output from trying to compile modules none

Description Harry Gold 2002-10-26 01:29:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
I need to build modules for lp, parport and ppa to use my ZIP drive and 
printer. Using kernel 2.4.18-14, I do a bzImage compile. I need try to compile 
the modules using "make modules" The first module that is attempted to 
becompiled is the lp module from /drivers/char. I get numerous warning messages 
but I will attach the modules.out file with all of the error messages



Version-Release number of selected component (if applicable): 2.4.18-14


How reproducible:
Always

Steps to Reproduce:
1.Build bzImage kernel with parport, lp, and scsi/ppa set as modules
2.attempt to make modules after kernel compile is finished
3.
	

Actual Results:  Received error messages about invalid suffix on integer 
constant and parse error before numeric constant

Additional info:

RH 8.0 was obtained from mirror site and disks were checked before installation

Comment 1 Harry Gold 2002-10-26 01:33:13 UTC
Created attachment 82164 [details]
Output from trying to compile modules

Comment 2 Arjan van de Ven 2002-10-31 17:31:53 UTC
looks like you forgot a "make mrproper" as very first step

Comment 3 Harry Gold 2002-11-01 22:43:35 UTC
Using mrproper fixed the problem however, it was not obvious from the 
documentation that I looked at