Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76678

Summary: Installer won't install module for aha152x scsi controller
Product: [Retired] Red Hat Linux Reporter: swbobcat
Component: installerAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-30 22:50:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description swbobcat 2002-10-24 21:10:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
During the install of Redhat 8.0 from a floppy, the driver disk is inserted to
add the aha152x module for the scsi controller.  It reports that the module is
installed but on the Alt F4 console it showed an error for the software
interrupt (in the default case, 11).  The parameters had been specified
correctly and various combinations were tried.  This controller (module) worked
fine with Redhat 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot with boot floppy (boot.img) choose install from disk.
2.Insert driver disk when prompted (drvblock.img).
3.Load aha152x scsi module with appropriate parmaeters
  (aha152x=0x340,11,7)
4.Watch it blow up (actually an infinite loop).
	

Actual Results:  It returned an error on console Alt F4 and loops back to prompt
for CD vs. disk drive distribution.

Expected Results:  It should have loaded the driver and moved on to disk
partitioning.

Additional info:

Comment 1 Dave Strandberg 2002-10-27 23:25:28 UTC
See also bug #74879.  

Problem also mentioned at http://sourceforge.net/forum/forum.php?
thread_id=712594&forum_id=33429.

Will new installation images be required to install RH8.0 on aha152x scsi 
devices?

Comment 2 Jeremy Katz 2002-10-31 20:37:17 UTC

*** This bug has been marked as a duplicate of 74879 ***

Comment 3 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 4 peterw 2003-03-04 16:20:27 UTC
I need a new set of install disks (boot.img and drvblock.img) so I can install
off my internal CD-ROM drive. At least then I can pull the new kernel packages
off the network so the SCSI devices continue to work.

I'm adding this note b/c the updated packages at
http://rhn.redhat.com/errata/RHSA-2002-206.html are irrelevant if I can't run
the installer. :-(

Thanks.