Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76649

Summary: redhat-config-network (neat) crashes upon clicking the ADD button in the DEVICES tab
Product: [Retired] Red Hat Linux Reporter: Ack <spamcan>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: bzhang, winnyval
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-02 19:20:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
traceback from neat
none
Traceback neat:1402 none

Description Ack 2002-10-24 16:21:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Unlike similar bug posts against neat, the EDIT button does not cause a crash. 
The ADD button crashes immediately and yields the attached traceback.  Appears
to be a problem enumerating the list of options that normally appears after
clicking the ADD button.  Crash occurs with or without the presence of
/etc/wvdial.conf.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/neat
2. Click the ADD button
3. Crash
	

Actual Results:  Unhandled Exception.  See traceback.

Expected Results:  Display the normal 'Add New Device Type' dialog with a list
of device types to choose from.

Additional info:

Just noticed that launching internet-druid causes what appears to be the exact
same unhandled exception:

-----------------------------------
File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description
-----------------------------------


Unhandled Exception from neat:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description





Unhandled Exception from internet-druid:

Traceback (innermost last):
  File "/usr/sbin/internet-druid", line 1400, in ?
    window = mainDialog('druid')
  File "/usr/sbin/internet-druid", line 238, in __init__
    if modus == 'druid': self.on_deviceAddButton_clicked(None)
  File "/usr/sbin/internet-druid", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Comment 1 Ack 2002-10-24 16:22:34 UTC
Created attachment 81944 [details]
traceback from neat

Comment 2 v.chavez 2002-10-25 15:39:13 UTC
aha
I have this problem...
what should i do to correct this?


Comment 3 Michael Schwendt 2002-10-27 22:41:00 UTC
Duplicate of bug #76446. Go there for a fix.

Comment 4 Need Real Name 2002-11-02 19:02:50 UTC
Created attachment 83204 [details]
Traceback neat:1402

Comment 5 Need Real Name 2002-11-02 19:20:15 UTC
Hi all,

Today, I updated my kernel 2.4.18-17.7.x on i686 (AMD Athlon XP).
I had the same pb with 2.4.18-10 but it worked with 2.4.18-3 (intallation with CDs).
When I use KDE (kernel 2.4.18-17.7.x), I haven't got any pb to connect.



Comment 6 Harald Hoyer 2002-11-04 12:55:41 UTC
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

*** This bug has been marked as a duplicate of 76446 ***