Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7662

Summary: quota command not working on non-Linux clients
Product: [Retired] Red Hat Linux Reporter: djschaap
Component: nfs-utilsAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-14 17:55:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description djschaap 1999-12-07 20:31:17 UTC
Using the following configuration, the "quota" command on various other
UNIX clients seems to be reporting incorrect sizes or none at all.


NFS server:  RedHat Linux 6.1
kernel-2.2.12-20
knfsd-1.4.7-7


RedHat Linux 6.1 client:
$ quota
Disk quotas for user foo (uid 1026):
     Filesystem  blocks   quota   limit   grace   files   quota   limit
grace
myserver:/export/home/foo
                  11260  100000  101000             255       0       0


HP-UX 10.20 client:
$ quota -v
Disk quotas for foo (uid 1026):
Filesystem     usage  quota  limit    timeleft  files  quota  limit
timeleft
/home/foo
              45008 400000 404000                255      0      0


FreeBSD 3.3-RELEASE client:
$ quota -v
Disk quotas for user foo (uid 1026):
     Filesystem  blocks   quota   limit   grace   files   quota   limit
grace
           /mnt   45040  400000  404000             255       0       0


IRIX 6.5.5m simply reports no quotas for that user.

Comment 1 Cristian Gafton 2000-08-09 02:34:23 UTC
assigned to johnsonm

Comment 2 Stephen John Smoogen 2003-01-25 00:09:21 UTC
Does this bug still occur in Red Hat Linux NFS servers of 7.3 or 8.0? There were
major changes in the code by going to 2.4 kernels and other quota additions.

Comment 3 Jay Turner 2003-04-14 17:55:35 UTC
Closing out due to bit-rot.