Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7637

Summary: Quotas on server not updated on chown() from NFS client
Product: [Retired] Red Hat Linux Reporter: Bob Farmer <redhat>
Component: nfs-utilsAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: federico.cozzi
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-14 17:56:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bob Farmer 1999-12-06 19:17:46 UTC
When an NFS server machine is using an ext2 filesystem with quotas enabled,
and has the filesystem exported via NFS to a client machine, and the client
machine creates a file then chown()'s it to another user, quotas do not get
correctly updated on the server.  I have tested this with a stock RedHat
6.1 server and client combination.

For example, on a server, create an ext2 filesystem and a directory
/export.  Setup and enable quotas on /export.  Export /export to a client.
On the client, mount /export.  On the client, create a large file owned by
root in the mounted filesystem.  Then chown() it to another user.  The file
will still count against root's quota as far as the server machine's quotas
are concerned.

Comment 1 Cristian Gafton 2000-08-09 02:35:13 UTC
assigned to johnsonm

Comment 2 Stephen John Smoogen 2003-01-25 00:53:25 UTC
With the major changes in NFS, kernel, and quota between 7.0 and the 7.3 release
is this bug still active?

Comment 3 Jay Turner 2003-04-14 17:56:32 UTC
Closing out due to bit-rot.