Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 76123

Summary: installer hangs with traceback error (OS Error:[Errno 12] Cannot allocate memory
Product: [Retired] Red Hat Linux Reporter: Need Real Name <george.stewart>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: ajweltman, alebec, chandra_s_prasad, dghinds, erikheidt, joegreco, kakurathi, kitm, luis, mevett, mherrick, rdjurovich, redycom, stock, urvishjani, zeed_777
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-10-24 19:00:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2002-10-17 06:07:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Version 7.3 installed fine with same hardware but not 8.0. Goes through whole 
intallation setup including hard drive partitioning and install packages and 
dependancies but then halts with traceback report. System is Gateway 2000 P5-
120 with STB Trio 64 video card (S3) and Vivitron 1572 (Sony) monitor. Disk 
drives are WD 5.1GB (Linux) and WD 1.6GB (Windows 98)dual booting. Doing 
install of workstation

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./boot 100mb
2./      4.9Gb
3./swap 100mb
	

Actual Results:  get Traceback error everytime:

Traceback (most recent call last):

file "/usr/anaconda/gui.py", line 786 in handleRenderCallback
      Self.CurrentWindow.renderCallback()
file "/usr/lib/anaconda/iw/progress_gui.py", line 149, in 
renderCallbackself.intf.icw.nextClicked()

file "/usr/lib/anaconda/gui.py", line 632, in nextClickedself.dispatch.gotonext
()
file "/usr/lib/anaconda/dispatch.py", line 150, in gotoNextself.movestep()
file "/usr/lib/anaconda/dispatch.py", line 215 in moveStep
  rc=applx(func,self.bindArgs(args))
file "/usr/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetadeletes (diskset)
file "/usr/lib/anaconda/partions.py", line 1110, in doMetaDeletes
lvm.Vgactivate
file "/usr/lib/anaconda/lvm.py", line 54 in vgactivate
  searchPath=1)  ** note single bracket **
file "/usr/lib/anaconda/iutil.py", line 66, in execwithRedirect
   childpid=OS.fork()
OSError: [Errno 12] Cannot allocate memory

Expected Results:  should have proceeded to format the partitions and then 
start install of packages.

Additional info:

using boot.img to boot from floppy disk to CDROM. Tried image from 8.0 
distribution and also from 7.3. Two drive are HDA (windows 98) and HDB for 
Linux. Installation works fine for 7.3. Tried both ext2 and ext3 partitions. 
Suspect either a formating problem of HD or video problem. Using Personal 
package just bought and received (not ISO downloads.

Comment 1 Jeremy Katz 2002-10-18 15:44:48 UTC
How much memory do you have in your machine?

Comment 2 Need Real Name 2002-10-18 17:06:27 UTC
There is 64mb of memory in system

Comment 3 Need Real Name 2002-10-21 19:58:36 UTC
the system has 64 mb.

Comment 4 Akurathi Krishna 2002-10-22 03:30:01 UTC
I am also ruuning into same problem. I am booting the system using MS-DOS disk 
and ending with the above error. I changed few options and the problem is always
showing up. I did not test with Linux7.2. This problem is Linux Installer8.0.

Comment 5 Alejandro Ron 2002-10-23 16:41:30 UTC
I have the same ploblem. My PC is a IBM NetVista 6269-R3S, Intel Pentium III 
600MHz, 64 Ram, HD 13GB IBM, Video Intel 810, Monitor IBM G42.

I don't have any partition on the HD. I'm using RedHat Linux 8.0

Comment 6 Alejandro Ron 2002-10-23 16:47:04 UTC
The program also told me that my HD have an inconsistent geometry and 
recommends me to use LBA. And that this could not affect the use of it.

Comment 7 pladab 2002-10-24 07:50:39 UTC
i have met the same error problem.
please told me how i can fix it.

Comment 8 Arnaud LEBEC 2002-10-24 12:39:24 UTC
I get the same problem when i try to install 8.0 on my Toshiba Laptop.

I couldn't install 7.3 on this machine (it booted from diskette, caught signal
11 in /sbin/loader), so i tried to install 8.0.

8.0 lets me do all parametering, until i finally launch the installation, and
then getting the tracaback error, without possibility to save it to a floppy
(doesn't work...).


Does anyone know how to fix that ?

Comment 9 Need Real Name 2002-10-24 14:18:14 UTC
I've got a Pentium 166 w/64MB memory - 1GB, 3GB, 6GB IDE hard drives - I get 
this on floppy/CD install of Linux 8.0:

...
File "usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(diskset)
File "usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
  lvm.vgacivate()
File "usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1)
File "usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

install exited normally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc done
	/dev/pts done
	/mnt/source done
you may safely reboot your system

Comment 10 Jeremy Katz 2002-10-24 19:12:47 UTC
Going back in graphical mode with only 64 megs of ram seems to exhaust available
memory.  Please boot with 'linux text' and do a text mode install or go forward
through the install process.  I've bumped the numbers in CVS for turning on swap
early.

Comment 11 Need Real Name 2002-11-16 00:34:42 UTC
I do have an Dell Pentium III, with 128mb and I am getting the same annoying 
message and the installation quits. It does not happens with 7.2 and 7.3. 
Should be a bug. Is there any other solution, rather than installing using the 
text only facility ?
Thanks,
Andre.

Comment 12 Need Real Name 2002-11-16 00:38:15 UTC
I would like to appologize for my last message. My computer does have only 64mb 
and NOT 128Mb as I wrote. So probably I am having the same memory problem. But 
anyway the installation program should work fine with 64Mb like the earlier 
versions.

Comment 13 Need Real Name 2002-11-19 20:44:28 UTC
I have a Pentium 133 mhz with 40 MB memory installed and I'm having the same 
problem. Can I work with version 7.3 in graphical mode with this amount of 
memory? Can somebody give the answer to this question?

Comment 14 Andreas Griesser 2002-12-01 20:02:59 UTC
I too got this traceback error with Redhat 8.0 booting from floppy and 
installing from the ftp site.


I have a P4 2,67 GHz, 512MB RDRAM, 80GB HDD partitioned with 100MB /boot, 1GB 
swap, 10GB /, 60GB /workpartition. Except of swap the filesystem is ext3.




The installation reports an error reading the partition table from this 
harddisc.


Comment 15 Need Real Name 2002-12-11 13:01:56 UTC
I had same problem installing RH 8.0. Had 64mb RAM and adding 128mb goes fine, 
i finished instalation with anaconda ok !! :)
Anyone have other less expensive solution??


Comment 16 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 17 Jeremy Katz 2003-01-10 06:55:32 UTC
*** Bug 78756 has been marked as a duplicate of this bug. ***

Comment 18 Jeremy Katz 2003-01-11 06:55:36 UTC
*** Bug 78719 has been marked as a duplicate of this bug. ***

Comment 19 Need Real Name 2003-01-21 14:50:51 UTC
*** Bug 82047 has been marked as a duplicate of this bug. ***

Comment 20 Jeremy Katz 2003-01-22 06:02:03 UTC
*** Bug 82164 has been marked as a duplicate of this bug. ***

Comment 21 Jeremy Katz 2003-01-29 21:44:24 UTC
*** Bug 82881 has been marked as a duplicate of this bug. ***

Comment 22 Jeremy Katz 2003-01-29 22:01:28 UTC
*** Bug 82452 has been marked as a duplicate of this bug. ***

Comment 23 Greg Hinds 2003-01-30 04:23:05 UTC
Why was this closed?

Comment 24 Matt Evett 2003-02-06 21:44:47 UTC
*** Bug 83067 has been marked as a duplicate of this bug. ***

Comment 25 Jeremy Katz 2003-02-07 20:47:47 UTC
*** Bug 77598 has been marked as a duplicate of this bug. ***

Comment 26 Jeremy Katz 2003-02-14 17:26:13 UTC
*** Bug 84130 has been marked as a duplicate of this bug. ***

Comment 27 Need Real Name 2003-03-03 16:08:27 UTC
Is there a workaround or fix that can be downloaded to get allow installs on 
machines with 64M?


Comment 28 Michael Fulbright 2003-04-22 16:18:25 UTC
*** Bug 85067 has been marked as a duplicate of this bug. ***