Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7546

Summary: rpc.mountd dies
Product: [Retired] Red Hat Linux Reporter: Rex Dieter <rdieter>
Component: nfs-utilsAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 7.0CC: ung
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-09 02:34:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rex Dieter 1999-12-03 16:04:38 UTC
About once every few days or so, our Linux NFS server (knfsd-1.4.7-7)
stops servicing new NFS mount requests.  The cause of this seems to be
because the rpc.mountd daemon dies.  This also occurred with redhat 6.0
(using rawhide's knfs-1.4.7-7).

This seems to be similar to BUG #2707.

To fix this, all I do is either manually restart the daemon
(/usr/sbin/rpc.mountd --no-nfs-version 3) or reboot the server.

Comment 1 Jeff Johnson 1999-12-03 16:44:59 UTC
What kernel are you using? There are kernel patches that must match with
knfsd version (ugh).

Comment 2 Rex Dieter 1999-12-03 16:48:59 UTC
It occurs both with the stock redhat-6.1 kernel (2.2.12-20) and with rawhide's
2.2.12-42 kernel.  Which would you recommend?  (I'm sticking with the "stock"
kernel for now).

Comment 3 Rex Dieter 1999-12-08 20:36:59 UTC
This seems to be a repeat, or, at least very similar to bug #7024

Comment 4 Rex Dieter 1999-12-16 17:05:59 UTC
I've verified the circumstances upon which rpc.mountd dies in that it dies in
conjunction with ypserv/ypbind problems (which may lead to my reporting bugs for
them).  Anyway, shortly before each time rpc.mountd died, I also had in
/var/log/messages, the errors:
Dec xx xx:xx:xx server ypserv[310]: WARNING: ypserv has to many running children
! We don't fork
THEN, got a few of the form:
Dec xx xx:xx:xx mountd[28864]: client.domain.com has non-inet addr
THEN, after a few more of both of those, rpc.mountd died.

As a fix, I chose to NOT use NIS for hostname lookups by editing
/etc/nsswitch.conf to include a hosts directive as:
hosts:	files dns

Since making this change (it's been over a week), I have not experienced a
single rpc.mountd crash.

Comment 5 Cristian Gafton 2000-08-09 02:34:25 UTC
assigned to johnsonm

Comment 6 Rex Dieter 2001-05-10 14:56:14 UTC
I am happy to report now much later that I have not experienced an rpc.mountd 
crash since the last time I reported it.  For the record, I'm now running:
kernel-2.2.19-6.2.1
nfs-utils-0.3.1-0.6.x.1
glibc-2.1.3-22

So, I personally consider this bug closed.  I'll mark it resolved by "errata", 
as I think some combiniation of the upgraded components I mentioned above 
probably fixed it.