Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7519

Summary: zic produces bad symlink
Product: [Retired] Red Hat Linux Reporter: adam
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-24 23:37:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description adam 1999-12-02 22:01:12 UTC
After using zic to change timezones, my system date was messed up.  This
also had interactions with cron, and probably other stuff.  The workaround
is obviously to give a full pathname to zic.

I rated this as a glibc problem because rpm -q -f `which zic' reports
glibc-2.1.1-6

% date
Thu Dec  2 16:50:06 /etc/localtime 1999
/* Well, thats a bogus time of day */

# zic -l Canada/Eastern
"command line", line 1: warning: hard link failed, symbolic link used

# ls -l /etc/localtime
lrwxrwxrwx   1 root     root           17 Dec  2 16:55 /etc/localtime ->
../Canada/Eastern

# zic -l /usr/share/zoneinfo/Canada/Eastern
"command line", line 1: warning: hard link failed, symbolic link used

# ls -l /etc/localtime
lrwxrwxrwx   1 root     root           37 Dec  2 11:56 /etc/localtime ->
..//usr/share/zoneinfo/Canada/Eastern

Comment 1 Cristian Gafton 2000-05-22 14:52:59 UTC
assign to jakub

Comment 2 Stephen John Smoogen 2003-01-24 23:37:29 UTC
Bug 7519 seems to have been fixed since 6.0 either in newer versions of glibc or
other means. It is recommended to use the redhat tools for changing the timezone.